No Transformation Window, No F8 Shortcut

Hello, me again with the very simple questions.

I am using Big Warp to alter images so that they align, which are being used to train autonomous cameras to recognize components from the images via Deep Learning.

While I do have access to the “export warped image” function which alters the image based on landmarks, I have no idea what this transformation is actually doing. I need access to the different types of transformations (Translation, Similarity) so I can compare the error margins, but there is no transformation window which allows me to apply them-- I can’t find it anywhere.

In addition, the F8 shortcut listed on the Big Warp homepage does not work. It had no effect when I ran the software on my Windows or Mac system.

From what I’ve read online, these are not isolated issues. Please help!

1 Like

Hi Kate (@katealice45),

Thanks for reporting this.

Regarding F8 and transformation type selection being broken:
I’m aware of this, it’s fixed now and will be in the next release.

If time is not an issue you can wait until the next release.

On the other hand, if you’re in a rush, you can:

  1. Fall back to an older Fiji / bigwarp before this issue popped up.
  2. Move ahead to the current development version of Bigwarp.

Option (2) may be trickier if you havn’t compiled java code before.

Let me know what you’d like to do and I’ll be happy to help

Hi John,

I would like to fall back on a version of Fiji/BigWarp before the issue occurred. Can you walk me through the steps to do so?


Hi Kate ( @katealice45 ),

You can find a list of archived fiji versions from various time here:

The transform type selection in bigwarp worked for me in this version from January 2019

Let us know if that works for you too,

1 Like

Hi John (@bogovicj),
Follow-up on this issue: While this version worked for me, I’m still having the issue of a broken F8 (and also F6) keys in the BigWarp release that currently comes with Fiji (6.0.0). According to the github issue this should be solved in 6.0.2 - is this available through the Fiji update yet?



Following on this, I just leant today that F8 is now replaced by F2 on the latest Fiji versions.


1 Like