Newly downloaded MCRInstaller and CellProfiler can't be used

cellprofiler

#1

Hello,
I am a user of Cellprofiler. I have been used it since Sep, 2006. At that time, I downloaded the MCRInstaller.exe(6.0) and PC_CellProfilerv1.0.3544.64bit and it worked well in my computer. But today, I find there are new version about it, so I delete the old version and download MCRInstaller.exe(7.5) and PC64_CellProfilerv1.0.4553. It appears“× .NET Framework is not installed. If you require it, select Cancel and install.NET Framework first. Otherwise, select OK to continue” in the course of the installation of MATLAB Compoment Runtime 7.5. I choose “OK” and don’t know the influence to others. Then, I run the Cellprofiler but I find I can’t add to pipeline. In the C:, it appears:
??? One or more output arguments not assigned during call to “deploywhich”.
Error in = => fopen at 16
Error in = => CellProfiler>PutModuleInListBox at 6395
Error in = => CellProfiler>AddModuleListBox_Callback at 9586
Error in = => CellProfiler>gui_mainfcn at 10475
Error in = => CellProfiler at 65
??? Error using = => set<gcf, ’SclectionType’,’open>;CellProfiler<’AddModuleList B
ox_Callback’,gcbo,],guidata>
One or more output arguments not assigned during call to “deploywhich”.
??? Error while evaluating uicontrol Callback

I don’t know the meanings. So I want to download the old version but there are no in the “download”. I feel nervous about Cellprofiler and don’t know how to do.

Thanks a lot for your help.

Chen Na


#2

Hi Chen Na,

I strongly recommend upgrading to the latest version as many bugs have been fixed during this time. Here are the possible explanations I have and how to fix:

  1. Conflict with old MCRInstaller. Fix by going to Control Panel and uninstalling the old MCRInstaller before installing the new one.

  2. Modules folder location is incorrect. Go to File -> Set Preferences within CellProfiler and make sure the Modules folder is correct.

Please let me know if this helps!

Mike


#3

Hi,

The new version of CellProfiler can work well in my computer. I’m very happy. It worked wrong before because I am a Chinese and install the MCRInstaller in a folder that is named with Chinese. Maybe the Modules folder can’t be found and is incorrect.

Chen Na