Newbie asking installation of packages (extensions)

qupath
#1

Hi,

I have a problem installing QuPath packages in my desktop (Window 10).

First I downloaded QuPath 0.2.0 and installed it in ‘My document’.

I then downloaded;

I unzipped above zip three zip files under ‘My document’ but different folder respectively.
I did not see any installation file for above files.

Then, I started a command prompt, and move to the folder containing Qupath-0.2.0.exe file.
Then I ran ./gradlew.bat createPackage -Ppackager=/path/to/jpackage
I got error message saying; ‘.’ is not recognized as an internal or external command,
operable program or batch file.

Can anybody tell me what I have done wrong or how to have packages installed in Qupath in my situation?

0 Likes

#2

Not sure what your situation exactly is, but the QuPath 0.2.0m2 download is standalone. You unzip it into a folder and then just run it from the exe file within the base unzipped folder. There is no Gradle involvement, nor do you need to install anything.

0 Likes

#3

If the question is more about jpackage itself, you might want to check stack exchange or something like that.

https://blogs.oracle.com/jtc/a-brief-example-using-the-early-access-jpackage-utility

0 Likes

#4

Thank you so much from your answer.

I did not know that it is standalone. I noticed that it runs by itself. When I load the image file from ZEISS microscopy (.czi), QuPath does not seem to completely recognize .czi. For instance, it did not automatically pick up image type or stains of image. Also, there are only three options that I could choose for image type; Fluorescence, Others, Not sure. None of them are of my interest since my image is IHC-DAB.

That is why I thought I needed more extensions or packaging to make it fully functional. But if it is standalone, maybe it just does not completely read .czi I assume? I will save image file as TIFF and try again to see if it works.

0 Likes

#5

There is a new default that forces you to choose the image type, rather than automatically estimating it due to occasional errors in the estimation by the older versions of the software. You can turn the auto-estimate back on in the Preferences menu. You can also still set the image type by one line in your script, or by the Image Type entry in the Image tab on the left.

CZI images mostly should work, though there are problems depending on:
A. Bit depth higher than 8 brightfield images won’t work due to the way QuPath handles brightfield images. Some of the Java code used to analyze them apparently won’t work at higher than 8 bit depth (I don’t know more details than that).
B. Tiled 8bit images (from say, an Observer) are currently problematic and I have an open post about this on the BioFormats GitHub site. This is a BioFormats issue, feel free to post there if your problem is related.

0 Likes

#6

Thank you so much for your quick response.

I just found out that my czi file was 16 bit. I will convert it to 8 bit and try again to see it automatically detects IHC-DAB.

I appreciate your advice.

Best,

Bumjun

0 Likes

#7

I ended up swapping to taking the images with the Observer set to 8bit, as I really do not like the way the compression worked on our 14 bit images. Hopefully you will have better luck with the 16bit versions. I have a feeling Zen was compressing the 14bit values as if they were 16, resulting in poor quality images.

0 Likes

#8

I tried opening 8bit .LSM file but QuPath could not do auto-estimation for this file format as well. So I converted it to 8bit TIFF file then it finally worked.

Thank you so much for your help.

Best,

Bumjun

0 Likes