NDPITools - Unable to run plugin


I have been unable to run the NDPITools plugin, specifically, I have been unable to ‘Custom Extract to TIFF/Mosaic’ - (I am also unable to even preview the NDPI).

When I try to extract I receive the error message ‘No image was extracted by NDPIsplit’

I have tried across Fiji and ImageJ, I have updated Java to the newest version. I have uninstalled and re-installed ImageJ and the plugins several times (including the .jar file and the associated .pkg file). I have also tried across 2 X different Macs (laptop and desktop both running OS X Catalina) and 2 X PC (1 accessed via remote desktop and 1 virtual machine). I am particularly confused as a colleague of mine has had success following the exact same downloads and procedures on the very same PC remote desktop and virtual machine directly after me.

Any help provided would be much appreciated as I am fresh out of ideas!

Kind Regards,


I have not used this tool myself… though I did invite the developer of this tool here. Hopefully, he will respond.

You might want to also check out this discussion for alternative options to split NDPI files: Image J, Slide J plugin-Unable to save all mosaic tiles?! Help!

1 Like

dear biancagee,
Qupath can manage NDPI files thank you petebankhead

NDPI tools is a bit difficult when you try it the first time.
Are you sure that you don’t have any space or specials charaters/letters in the name of your file ?

  • first you need to download ndpisplit AND NDPITools_
  • then you really need to define how you want to extract your file
  • tile or not
  • the compression etc…
  • I really had some trouble with big file. If you want to extract 40x magnification +/- 50Go fiji can’t handle this file. usually I open 10x or 5x

Can you send me a file, I suppress all my .ndpi from my computer and I will help you.


1 Like