Multiview reconstruction plugin CUDA activation

Hi everyone,
I’m using this great plugin Multiview reconstruction and i would like to optimize its speed.
I’m trying to execute the plugin with CUDA activation but when i run it with the CUDA option on, it crashes with no error log.

I have followed the instructions offered in the link below, but with no results

Has anybody (@StephanPreibisch) had similar problems or has some ideas how to activate the CUDA option?
Thank you in advance.

Hi Dimitris,

If you want to get in touch with the developers of the multiview reconstruction directly I would suggest to post an issue on github directly:

I think these days the main focus shifted towards the BigStitcher plugin so you might get help there as well:

I think if you want to trouble shoot the GPU accelerated processing it would be good to also include information about your workstation (GPU model, GPU memory, RAM, Operating system etc) as well as what you did specifically when building the CUDA libraries as well as when using the Multiview reconstruction.

My tip is to always try downsampled data first. In my experience in the past such problems indicated a memory issue that just crashes Fiji without error.


Dear Christopher,
Thanks for your reply, and suggestions.
I can run the same routine without CUDA, just based on the CPU and RAM of my computer, so i would not expect it to be a memory issue, but you never know.
Even with downsampled data it does not work

My system is running Win10, 64GB RAM, NVIDIA Quadro P200 4GB.

I build the CUDA libraries as described in this link (
I only changed this line

cmake.exe -G “Visual Studio 15 2017 Win64” -

to account for the different version of visual studio that i have installed.


Well it depends also on the memory of your GPU.
Try to run it with downsampling applied. Plus use a predefined bounding box! It is really important to reduce your memory footprint as much as possible.

For the downsampling you would need to run an external transformation by:
Plugins > Multiview Reconstruction > Batch Processing > Tools > Apply Transformations

Use a uniform transformation matrix for that such as:
0.5, 0.0, 0.0, 0.0, 0.0, 0.5, 0.0, 0.0, 0.0, 0.0, 0.5, 0.0
for 2x downsampling

Here you find some more hints for configuring the multiview deconvolution:

Thanks for the tips, very useful!

I use a very small data set, but FIJI still crashes.
It might be the memory but it sounds strange not being able to run two views of 6 MB each.
The required memory for deconvolution for such data set is 96 MB.

I’m wondering if there is some conflict with the graphics card.
The building of the libraries seems to be successful, at least they are created, and I place them in the FIJI folder. FIJI seems to recognize them, but when it comes to running the deconvolution it crashes.

Hm that would indeed be strange. But without further error messages or any feedback from the system it is hard to find out what goes wrong.

In this situation I would default to making sure to use an up to date Fiji (fresh download then Help > Update). Then make sure Fiji uses sufficient system resources (70% of RAM) via Edit > Options > Memory & Threads.

While processing I would then monitor the resources using the Task Manager and the NVIDIA System Monitor and see if the processing is actually starting or if there is a memory leak leading to the crash (you see that the memory usage goes up until there is a crash).

Then I would get in touch with the developers of the Multiview reconstruction and report what I observed. Also look here directly for compiling the libraries:


Thanks for your help, probably it is a good idea to contact the developers directly.
I will update the forum once it works out.