Multiplex composite but only 3 Channels (RGB) showing on QuPath. Bio-Formats extension not working

I want to analyze fluorescent files with staining in 5 channels (4 + DAPI). In tutorials, people have multiple channels viewable in ‘Brightness and Contrast,’ but I only have RGB.

I attempted to install the QuPath Bio-Formats Extension (as explained here: GitHub - qupath/qupath-bioformats-extension: Extension to add Bio-Formats image support - **QuPath v0.1.2 only**) but when dragging the JAR files am met with ‘ERROR: Extension error: Unable to load Bio-Formats server options (Bio-Formats 6.5.1)’ and ‘ERROR: It is recommended that you delete file:/C:/Users/DavidJ/QuPath/extensions/qupath-extension-bioformats.jar and restart QuPath.’ I have deleted the extension and tried again to no avail.

Even if the image I am analyzing is multiplex TIFF added directly as the composite created in RNAscope HiPlex, the pixel type shows up as uint8 (RGB). I’m wondering if this is the problem but it seems like this is not something I can change (from what I gathered in these forums:

https://groups.google.com/g/qupath-users/c/Z6E0xNhY-ik).

So how can I view more channels than RGB? To my understanding I can either do so via Bio-Formats (then how do I solve the extension error?) or simply cannot because the image is detected as RGB by the file reader. Please advise.

1 Like

Based on the lack of a version number on the top, it looks like you are not using 0.1.2, so the 0.1.2 only link you posted first does not apply. After 0.2.0 Bioformats is “built in.”

Could you elaborate on the method used to export? Or provide a sample file? It looks like, as you said, you have given QuPath an RGB image, so there should not be 5 channels at this point, and it is unlikely you can go back as you have “flattened” the file and destroyed the channel information.

Based on this paper: https://www.ncbi.nlm.nih.gov/pmc/articles/PMC7476812/
The file input does not say anything about a composite image, so I am guessing you created an RGB single image, and are not working with multiplex data anymore. You need to find some other way to export your data.

Just to be clear, this has nothing to do with manipulating the metadata - QuPath is not going to accidentally read a 5 channel image as a 3 channel RGB! You are feeding it an RGB image.

Extra note: thank you for providing the screenshot.

1 Like

The ‘S’ in the toolbar indicates selection mode, which wasn’t in QuPath v0.1.2 – so I assume it is indeed v0.2.

Also, the ‘Server type’ in the screenshot mentions that Bio-Formats is being used (although the image isn’t pyramidal – you can see this from the ‘Generated pyramid’ part).

I think @Research_Associate’s diagnosis is correct, and the image itself really is RGB. If you have Fiji installed, you can try reading it with that to compare.

@Research_Associate and @petebankhead thank you for your responses and the clarification about Bioformats. I am indeed using 0.2.3. My export method is directly from RNAscope HiPlex. I first overlap the images, save the composite image as a tiff on my desktop, then drag the icon to my open project in QuPath. Since RNAscope HiPlex is used for multiplex, I’m not sure where in the process the photo converts to RGB. I’ve attached screenshots of the flow from HiPlex to QuPath. Please let me know what you think.

1 Like

Here is a link to the composite tiff: Dropbox - Composite.TRKB.P2x4.IBA1.KCC2 7M Ligate + PB dorsal thalamus 4-13-21- JD.tiff - Simplify your life

Sounds to me like the paper was using


and building their own multichannel tiff. Based on that paper and what you have shown (I have no direct experience), the software may not support true multichannel image export - they leave it to you to do it on your own. The composite image is only for viewing.

1 Like

Thank you for all your help. I finally have the multichannel viewer! I saved all images in gray as above and opened them in ImageJ. Then I stacked the images and made a color composite image which is the file I imported to QuPath. Works great!

2 Likes

I would also recommend trying to ensure that your pixel size is set correctly during that process.
Image-> Properties…
Otherwise you could run into annoyances downstream.

1 Like

I recently merged the 13 channels in cell profiler and import into Qupath in tif file. But Qupath only read three channels for me.

Is there anyone who can help?. I already installed bioformat extension in qupath.

@HAY_MAR_OO I did not use Cell Profiler, but in ImageJ I made sure to ‘stack’ the images before creating the composite. Stacking the images converted the multiple images to one file, but did not visibly merge them. Instead, you could scroll through the different channels. I then saved this stacked image and opened in QuPath.

I’m not sure what the equivalent is in Cell Profiler, but if you decide to use Image J, first open all tif files. Then, select Image > Stacks > Images to Stack. Lastly, select Image > Color > Make Composite and save the file to open in QuPath. Hope this helps!

This is an issue with your CellProfiler settings; if you make a small change to those you shouldn’t see this issue.

2 Likes

I successfully ended up with image J stacking and can open in the QuPath. Thanks for help.