Multi-touch gestures: pinch-to-zoom not working

Hello,

I am using QuPath version 0.2.3 on Windows 10 machine.
When ‘use zoom touch gestures’ ticked:

  1. zooming works fine when using touch screen
  2. zooming does not work when using touch-pad. Instead, pinching in/out changes overlay opacity of the annotations.

Does anyone know what might be causing this issue and how to fix it?

Also, I’d like to say that I love using QuPath and big thanks to Pete Bankhead for developing it and sharing it freely.

Kasia

1 Like

Thanks Kasia :slight_smile:

The overlay opacity should change during scrolling while holding down the ctrl/cmd key. But if the shortcut key isn’t pressed, then it shouldn’t.

I’m afraid touch gestures can be a bit awkward, subject to exactly what computer / input device you are using (which is one of the reasons why they can be turned on/off – sometimes they are just quite frustrating). For example, on a Mac I might turn scroll gestures on if I am using a Magic Mouse but off if I’m using another kind of mouse, since they send QuPath different kinds of input notification. Some devices support scrolling left-to-right as well as up and down, while others require pressing shift to achieve that effect.

I’m limited in the range of devices I can test, and I’m not even sure it’s possible to access all the required information to fully support different devices in Java. Therefore I expect there isn’t an easy fix, and it is a matter of choosing which preferences are most comfortable for the devices you are using.

Hi Pete,

Thanks for your prompt reply and clarification.
Yes, as you say, on my computer, the opacity overlay does change during scrolling while holding down ctrl. But it also changes when I pinch in/stretch out on my touchpad, without holding any key.

The pinch-to-zoom worked on an Apple touchpad + Apple computer last time I used it (a few weeks ago). But somehow it doesn’t on Windows. If I figure out a solution (maybe there is some Windows-specific quirk or some way around it), I’ll post it here.

All the best,
Kasia

1 Like