Montaging images with different pixel scales in TrakEM2

Hello all,

I am trying to montage two stacks of ~ 1000 slices (.TIF SEM greyscale images). One stack is an overview of an area and the other stack is a region of interest within that overview (both collected from the same sample). Both stacks have nearly the same number of pixels (6k x 5k), however one stack has a pixel size of 50 nm and the other stack has a pixel size of 11.5 nm. I’ve set these properties for the stacks using FIJI (->Image->Properties; I’ve tried using nm, um, and pixels as units). Yet, when I import the stacks into TrakEM2, they open as though they are the same scale. For example (note these two images are from different regions in the stack - this is just for illustration purposes):

1

It appears as though TrakEM2 is just registering the number of pixels, and not their respective scale. Here is an example of what I’m hoping to achieve (I did this by approximately scaling the second image, also just for illustration):

2

Is there a way to get TrakEM2 to recognize the different pixel scales? Or perhaps I haven’t properly set the pixel sizes in the image metadata?

Thanks so much!

(PS I am able to ‘trick’ TrakEM2 by cropping and resampling the overview stack using Amira. When resampling from 50 nm to 11.5 nm, the Amira resample module adds pixels to the image so that when I load it into TrakEM2 it appears to be the correct scale. This is very cumbersome and time consuming however, and it requires decent computational power…)

Hi @Marcel_Sayre,

Welcome to the forum.

Yea, I experienced something similar to what you did. I imported images (from files) where the metadata gave pixel scales, but TrakEM2 didn’t seem to reflect that after import.

You can scale the images inside of TrakEM2 by right-clicking the patches, going to Properties, and then editing “scale x” and “scale y”.

Quite annoying that it doesn’t get that information from metadata though, I would call that a bug.
Would you consider filing an issue?

John

Hello @bogovicj,

Thank’s for your quick response! Unfortunately, I’ve tried just scaling the image, however scaling the image changes the resolution. I can export the image using the original resolution values, but that just blows up the low resolution image, making it pixelated (image on the left after export, image on the right is original):

3

Another option might be to downscale the image, montage it to the overview image, and then re-scale it before exporting it. I’ll try that and let you know how it goes. I’ll also file an issue, thank’s for that recommendation!

Marcel

1 Like