Missing texture measurements when running CP2 headless

When I run the developers version of CP2 for Linux headless on a pipeline that includes a MeasureTexture module and an ExportToSpreadsheet module (with the texture measurements selected for export), the resulting spreadsheet contains none of the texture measurements. All other measurements appear in the output spreadsheet. I have copied the first 31 lines of output below, and subsequent output is similar to lines 16-31 repeated for additional images.

When I use the same pipeline file on the same images with the gui version of CP2 for Mac, the resulting spreadsheets show all measurements including the texture measurements.

I think the problem is with the export module because if “Measure Gabor Features?” is checked in the MeasureTexture module, that measurement shows up in the output spreadsheet even when I run the program headless.

I have attached an example pipeline and two output files: one from a headless run on Linux without the texture measurements and using the Mac gui version of CP2 which includes texture measurements.

If you have any suggestions on how I can get around this problem or if you can identify something that I am doing incorrectly, that would be very helpful. Thank you!

  1. WARNING:root:Distributed support disabled: please install nuageux
  2. running build_ext
  3. skipping ‘_cpmorphology2.c’ Cython extension (up-to-date)
  4. skipping ‘_watershed.c’ Cython extension (up-to-date)
  5. skipping ‘_propagate.c’ Cython extension (up-to-date)
  6. skipping ‘_filter.c’ Cython extension (up-to-date)
  7. skipping ‘_lapjv.c’ Cython extension (up-to-date)
  8. skipping ‘_convex_hull.c’ Cython extension (up-to-date)
  9. WARNING: Java and JVM is not installed - Images will be loaded using PIL (‘NoneType’ object has no attribute ‘endswith’)
  10. INFO:root:Version: 2012-07-31T14:47:13 2cd4d2e / 20120731144713
  11. Version: 2012-07-31T14:47:13 2cd4d2e / 20120731144713
  12. INFO:PipelineStatistics:Pipeline saved with CellProfiler version 11710
  13. Pipeline saved with CellProfiler version 11710
  14. INFO:PipelineStatistics:Times reported are CPU times for each module, not wall-clock time
  15. Times reported are CPU times for each module, not wall-clock time
  16. INFO:PipelineStatistics:Fri Nov 9 10:50:25 2012: Image # 1, module LoadImages # 1: 4.68 sec (bg)
  17. Fri Nov 9 10:50:25 2012: Image # 1, module LoadImages # 1: 4.68 sec (bg)
  18. INFO:PipelineStatistics:Fri Nov 9 10:50:27 2012: Image # 1, module IdentifyPrimaryObjects # 2: 72.91 sec (bg)
  19. Fri Nov 9 10:50:27 2012: Image # 1, module IdentifyPrimaryObjects # 2: 72.91 sec (bg)
  20. INFO:PipelineStatistics:Fri Nov 9 10:51:40 2012: Image # 1, module MeasureObjectSizeShape # 3: 52.42 sec (bg)
  21. Fri Nov 9 10:51:40 2012: Image # 1, module MeasureObjectSizeShape # 3: 52.42 sec (bg)
  22. INFO:PipelineStatistics:Fri Nov 9 10:52:32 2012: Image # 1, module MeasureObjectIntensity # 4: 2.31 sec (bg)
  23. Fri Nov 9 10:52:32 2012: Image # 1, module MeasureObjectIntensity # 4: 2.31 sec (bg)
  24. INFO:PipelineStatistics:Fri Nov 9 10:52:35 2012: Image # 1, module MeasureTexture # 5: 59.49 sec (bg)
  25. Fri Nov 9 10:52:35 2012: Image # 1, module MeasureTexture # 5: 59.49 sec (bg)
  26. INFO:PipelineStatistics:Fri Nov 9 10:53:34 2012: Image # 1, module OverlayOutlines # 6: 7.18 sec
  27. Fri Nov 9 10:53:34 2012: Image # 1, module OverlayOutlines # 6: 7.18 sec
  28. INFO:PipelineStatistics:Fri Nov 9 10:53:42 2012: Image # 1, module SaveImages # 7: 2.54 sec (bg)
  29. Fri Nov 9 10:53:42 2012: Image # 1, module SaveImages # 7: 2.54 sec (bg)
  30. INFO:PipelineStatistics:Fri Nov 9 10:53:44 2012: Image # 1, module ExportToSpreadsheet # 8: 0.00 sec
  31. Fri Nov 9 10:53:44 2012: Image # 1, module ExportToSpreadsheet # 8: 0.00 sec
    Mac_gui_output_embryos.csv (8.27 KB)
    Linux_headless_output_embryos.csv (5.23 KB)
    ags-511-example.cp (7.25 KB)

Hi,
Does this same issue occur even if you have the “Select the columns of measurements for export” setting in the ExportToSpreadsheet module unchecked?
-Mark

That solves the problem! Thank you very much for your help.