Missing 'OK' and 'Cancel' buttons on Bioformats importer dialog box



Hi Guys
A very basic question, I open LIF files using BioFormats importer, and when I come to the Bio-Formats Series options, I am missing the ‘Ok’ and ‘Cancel’ button. I redownloaded FIJI and its still the same.
These buttons were on the left hand side of the box, with ‘select all’ and ‘deselect all’ being on the right side. Now, there are only the latter two…

Out of curiosity, does it have anything to do with the recent update, where it says this:
Thanks to Michael Schmid, on Linux, the “OK” button in GenericDialogs is now on the right, as it is on Macs.


How can I open my images?

For what it’s worth, I’m also experiencing the same issue after updating the BioFormats plugin. Was going to submit an issue on GitHub, but the issues list is completely empty over there - is there a different preferred mechanism for reports?


@pr4deepr you could try clicking ‘Select All’, then using the tab key to switch between buttons and then hit enter. It appears that the ‘Ok’ and ‘Cancel’ buttons still exist, they just aren’t visible/clickable right now. It looks like you’re out of luck if you only want to open a few selected image series, I haven’t got a workaround for that.


Yes, this seems to be a regression in ImageJ 1.51v. @Wayne, any comments?

Maybe this can be fixed on the bio-formats side, @dgault, @s.besson, @ctrueden?

If you only have a single or few selected series, it should be sufficient to hit Enter (since OK is the default action), or you can cycle the focus back from the first series (when it has the current focus) by pressing Shift+Tab twice and hitting Space. It’s not very convenient, but it works…


Hi @imagejan, this does indeed appear to have been introduced with changes to the GenericDialog in ImageJ 1.51v. The issue occurs independent of the version of Bio-Formats being used. From doing some testing the following line is the change which resulted in the issue and reverting that line resolves the problem.

This would appear to suggest that the problem is a conflict between the gridbag constraints being used in the updated GenericDialog and the Series Options window in the Bio-Formats plugin. I am currently testing some updates to the plugin to try and resolve the issue. I will attempt to have a Bio-Formats PR opened shortly with the aim of including a fix for Bio-Formats 5.8.1. I will keep this thread updated with the progress.

David Gault


Thanks @GenevieveBuckley and @imagejan for the prompt reply. Using ‘Enter’, as well as Shift+Tab and Space helped.

Thanks @dgault for your reply!! :slight_smile:


In ImageJ 1.51v, the line

c.gridwidth = 2;

in the showDialog() method of GenericDialog was changed to

c.gridwidth = GridBagConstraints.REMAINDER;

I suspect this change, made to get the dialog to display correctly when the new addToSameRow() method was called, is the cause of this problem. The latest ImageJ daily build (1.52a2) changes this line to

c.gridwidth = addToSameRowCalled?GridBagConstraints.REMAINDER:2;

Does the daily build fix the missing button problem? I am unable to very this fix since I cannot reproduce this problem.


Dear @Wayne,
for me this daily build has done the trick and the bug is fixed.
Thank you very much,


Hi @Wayne

Yes, the daily build has fixed the problem. Appreciate your help.

For those who want to update to the daily build (I just figured this out), go to Help->Update ImageJ->Upgrade To. From the dropdown box select ‘daily build’.



This regression is fixed in ImageJ 1.51w.