Missing metadata for Ventana images in QuPath with Bio-Formats

Hi, before the update the scalebar had a unit of µm (and mm) and after the last update this changed in pixels. Do anybody know if I can change this manually?

The scalebar units are based on QuPath reading the metadata. If your file type has pixel sizes, the scale bar should be in distance units. If not, pixels.

As shown in the second part of the first post, you can set that manually now (mostly for projects since it won’t be saved otherwise).

@K.massy There have been no (intentional) changes in this regard in m3. As @Research_Associate writes, QuPath will use the scaled units if it can read them. This is the case for any files I’ve checked.

If you have any images where you see different units in m3 compared when you open the same file with other QuPath versions, the first thing to check is the ‘Server type’ under the ‘Image’ tab. If these are the same then I’d probably need the file to investigate further.

Note that for the pixel location, there is an option to change this under Edit → Preferences… and then Use calibrated location text (this option isn’t new).

Thanks for your reply!
For example: when I open a scan from Ventana Scanner (TIFF format), the server type is for most of the scans Bio-Format and then I see pixels instead of µm. When the server type is OpenSlide I’ve got µm (and that is what I want :slight_smile:)
Even when I open an project, the Server type is Bio-Formats

Actually, I never noticed this.

If I open the same scans in the previous version of QuPath every scan/project has the same server type; OpenSlide…

So my question is: Do you know how to change Bio-Formats server types into an OpenSlide server type?

Interesting… m3 includes the latest Bio-Formats (6.2.0) which has added support for Ventana BIF images: https://www.openmicroscopy.org/2019/07/18/bio-formats-6-2-0.html

I presume that’s relevant but I don’t know much about this format or why the pixel sizes aren’t being provided. But under Edit → Preferences… in QuPath you can instruct not to use Bio-Formats with specific file extensions, and it should fall back to using OpenSlide.

You can see instructions here (but don’t install the extension on that page - Bio-Formats is already included now and the old exension isn’t compatible with m3!).

It may be worth investigating with Fiji & Bio-Formats whether there is a general problem with reading pixel size data or not. It would be good if Bio-Formats can offer support, because apparently there can be some weirdness using OpenSlide with some Ventana images, e.g. https://groups.google.com/d/msg/qupath-users/e5Fmt7lU43g/yFM8-Y_SBQAJ

1 Like

I encountered some of the same issues in previous versions with Ventana images, and can probably get you a copy of one for testing. I would always have to force TIFF on or off (for BioFormats) depending on whether it was a Ventana image.

Split to a new topic as it’s starting to see more of a Bio-Formats question.

I’ve checked if all our Ventana files are TIFF files and yes they are.

After this, I followed the steps @petebankhead said and when I turned this two settings off (see picture) every scan or project had the same Server type; OpenSlide!

image

For me this is perfectly fine and when I compare the scalebar from QuPath with the scalebar from Image Viewer (program from Ventana scanner) is it almost equal.

1 Like

@K.massy thanks for reporting your issue and glad switching back to OpenSlide addresses your immediate issue. As @petebankhead said, support for the the Ventana BIF file format was added in Bio-Formats 6.2.0 and included in the latest milestone of QuPath.

It looks like Bio-Formats is failing to read the physical pixel size from the proprietary file format in your case. Do you have sample files reproducing your issue that could be shared with us either publicly or by uploading them at http://qa.openmicroscopy.org.uk/qa/upload/?

Best,
Sebastien

@s.besson thanks for your reply. As mentioned, OpenSlide is working fine for me, however I do not know the additional value of using Bio-Formats in context of my own research.
I’d like to help you and others by sharing a sample file to see what the exact issue is and maybe solve this problem as well. Therefore, I uploaded one sample file via the link you provided me. If you find something interesting or things that can be optimized, can you please share this with me :smile:? I am still curious how some functions are working in the updated version!

Best,
Kimberly

2 Likes

Thanks for uploading the sample file Kimberly. We have been able to test and reproduce the issue and I have created a GitHub Issue to track the problem: https://github.com/ome/bioformats/issues/3416

2 Likes

Thanks for checking our sample!

When I copied the script in QuPath, it gave an error:
image

What does it mean and how can I change the script so that it is working again :)?

Do you (or someone) know if it’s possible to see the label of a scan cause that is the one thing in QuPath I miss and would like to see!

Sorry if Ive missed something, which script is this from? The label is certainly read and made available via Bio-Formats, Im not sure how to view it QuPath

I also don’t know what the script refers to, but there’s a command in QuPath View → Show slide label.

This doesn’t work for all formats, as QuPath relies on being able to identify the label image (e.g. by it being called ‘label’…).

You may also see a list of potential available label / overview images within the file under the ‘Image’ tab, if available. This should be a short list below the image properties/metadata. If you see it, you can double-click on an image to open it.

1 Like

First of all, sorry for my late response because I was on vacation!

After I upload a JPG file in QuPath (latest version 0.2.0-m4) and I turned these two option out:Enable Bio-Formats and Enable Bio-Formats tile parlallelization I saw that the scalebar again displays the unit in pixels…

The server type is now ImageJ server. Is OpenSlide the only possible way to get the scalebar back in µm (and mm)?

Kimberly

You really need two things:

  • the scale information to be stored in the image
  • an image-reading library that can find the information

Some image file formats don’t generally store the information - and JPEG is one of these formats. Therefore even opening a JPEG image with OpenSlide wouldn’t be enough, because the required information is (almost certainly) not there.

https://ori.hhs.gov/education/products/RIandImages/guidelines/guideline_10.html
Yep, avoid JPG images in general, though many whole slide image formats use it as part of their compreasion, it generally isn’t the primary file format, and it is the primary file format that contains the metadata you need for scale. Ventanas should be able to output TIFF files, among other options.