Missing Images Problem

Hi,
I’ve been using cell profiler successfully on the same batch of images for quite some time. However, today, for some bizarre reason, I can’t load my images. I’m pointed to the right folder. all the images are there. Everything looks kosher. I’ve attached a screenshot of the error message. The pipeline only contains the loadimages step. I must being doing something absolutely ridiculous.


Update: I can open each channel individually, but when try to open more than one image at a time it generates the error. I tried to load a different data set entirely, and did not have any issues.

Update 2: it seems to be a result of the size of my library. If copy and paste the first 1000 images it works, but it doesn’t work if I try to load all 13500. It had worked previously. Any clue as to what I could be doing wrong?

The can happen if there is a missing or duplicate image and thus there is a metadata conflict (even if you are not extracting metadata explicitly). If, at one site, you have say 2 instead of 3 channels because the microscope failed or the image was corrupted, then CP cannot load this cycle fully. The “Missing image” dialog pops up and tries to help you find the missing or duplicate image.

We’d like to be able to point to the culprit site rather than display the whole list, but unfortunately there are many potential failure modes. What I suggest doing is scrolling down the Missing Image dialog and see if you can find a mismatch between channels. If so, remove that site’s images and try again. Another method is just what you were doing – add half the data to the test input folder, run CP, if it works, then add another half, etc until you bisect to the troublesome site.

Let us know if that helps or not,
David