Missing evaluation-results files after training

I trained a network, but I cannot run ‘evaluate_network’ or ‘analyze_videos’ because the necessary files in ‘evaluation-results\iteration-1<experiment>-trainset95shuffle1’ are missing (i.e. not generated during training).

I do have the checkpoints, log, etc. in the ‘train’ folder. Is there any way to generate the files I need without training the network over?


EDIT: running train_network for a bit and retrying evaluate_network has fixed it.

I have the same error as above. I train and network but when I run evaluate_network I can’t the following error:

FileNotFoundError: File /root/Hoof_Detector-4-2019-03-09/evaluation-results/iteration-0/Hoof_DetectorMar9-trainset95shuffle1/DeepCut_resnet50_Hoof_DetectorMar9shuffle1_550000-snapshot-550000.h5 does not exist

I have tried training using different number of iterations, from 10,000 to 500,000 but I always get this error when I run evaluate_network. The training was successful and I can run analyze_videos successfully

Are the snapshots visible/saved in the folder?

Yes the snapshots are saved in the folder OK

then you likely just have a path error in your config file or [videoset]!

Have you solved the problem? I have the same problem :joy:
And I found that the file name it tried to find is a little bit different to what it created (labeled by red lines)


I think these errors are related to " File not found error – windows long file path (>260 characters) error" see here https://github.com/AlexEMG/DeepLabCut/issues/360 and here: https://github.com/AlexEMG/DeepLabCut/issues/196

1 Like

Yes, that’s the problem. I’ve solved it. Thanks!