Misaligned cursor when drawing Polygon Rois

In FIJI/IJ the cursor position is not aligned with the drawing position when using Polygon Roi tool.
This happens after zooming the image to a level at which it can not be displayed completely.
Here is an example:

test-1

My current FIJI/IJ version is

Is this due to my setup or is this a bug?

@phaub

  1. Is this a consistent problem that you are seeing? Ie - each time you shut down / restart - you see it again and again?

  2. Is it image-specific? Or so you see this with the sample images provided in Fiji… ?

You can try downloading and installing a new Fiji installation - and test it out.

I was not able to reproduce this … perhaps @Wayne has some insight on this?

Thanks @etadobson
for looking at this issue.

At the time of posting I thought the described problem would be very consistent.
I tested different version of FIJI, plain ImageJ and also FIJI from development environment.

The problem occurs only in the installation FIJI 2.0.0-rc-69/1.52u39 even after shut down and restart (100% sure).

My test image was a simple 8bit image 200x200 created with ‘New Image’ menu function.
(I don’t think that the problem is image-specific.)

Today I have tried to reproduce the situation (with the FIJI/ImageJ 2.0.0-rc-69/1.52u39 and with a new fresh FIJI installation before and after updating to IJ Nightly Build).

This time it took some time to force the proble to turn up (in FIJI 2.0.0-rc-69/1.52u39).
And this time it disappears after shut down and restart of FIJI.
It is unclear what is different this time.
And unfortunately I can not give a clear instruction to enforce it.

Today I used on 8bit image 1000x1000 created with ‘New Image’. (beside the 200x200 image)
I created PolygonRois and FreehandRoi, on different zoom levels, added them to the RoiManager, closed the RoiManager, created some more PolygonRois starting from low zoom levels and … suddenly … on higher zoom levels when only a part of the image is displayed … the cursor is shifted.

I tried this several times and forced the problem - sometimes more quickly and sometimes it took a while.
I am not sure what the critical action is.

In ImageJ 1.52v5 or FIJI/ImageJ 2.0.0-rc-69/1.52v5
it is easy to see a similar (but not identical) effect when starting to draw a PolygonRoi at low zoom levels and increasing the zoom level while the polygon is not finalized.
The difference to the descibed problem is that the effect disappears when a new polygon is started.

Maybe we can start investigating this temporary effect.

I think @Wayne should be informed.

@phaub

I cannot replicate this issue on my own computer…

This ImageJ 1.52u regression is fixed in the latest daily build (1.52v6).

2 Likes