Micro-manager 2.0 not detecting drivers automatically

Hello,

I am trying to set up micro-manager 2.0 on a pc that has micro-manager 1.4 already installed. When I try to create a new configuration, micro-manager is not detecting the devices, and when I try to manually add the microscope, i get the following message:

I made sure that the “OlympusIX3Control/OlympusIX3Control.exe” is present in the Micro-Manager 2.0 folder.

Thank you!

There appears to be an issue with connectivity to the IX83 after a recent Windows update. You may want to get in touch with your local Olympus person (I am asking them to make information how to fix this public, but things do not move very fast).

Our of curiosity: does 1.4 still work with the IX83? Do you have problems adding other devices in the HCW on 2.0?

Yes 1.4 still works with IX83.

I am having trouble with adding any of the devices that are working with the 1.4 version (ex. HammatsuHam camera, Olympus IX83…)

Which version of 1.4? The Olympus device adapter code has not changed since 2018-11-20. HamamatsuHam was recently updated (2021-03-15) and needs a recent version of DCAM (I guess 21.3 and newer) to work.

The version is 1.4.21. I tried using it today, and this is the first time I get this


The last time I had used the micromanager 1.4 was 2-3 weeks ago

That matches my earlier hypothesis this is caused by a Windows update. Olympus has a fix. I asked them to share the fix publicly, but so far no response. Please ask your Olympus person, and let us know what they suggest.

Just wanted to chime in here and say the exact issue is occurring with our setup. However, I tried to revert back to a previous windows versions without any luck getting micromanager to work - so it could be an issue that permanently became part of micromanager. I will also contact Olympus to see if they have a fix, and will post here if I find anything.

Olympus IX81? I would not say that it “has become part of Micro-Manager” as Micro-manager did not change, but the driver talking to the Olympus scope changed. I asked Olympus for a general response, but I am not getting anything out of them. Nothing I can do to help at this point I am afraid, please do ask Olympus.

Thank you all for your help!