MIB main menus not dropping down

Hi

MIB looks very promising, but after running the application the main menu options fail to drop down. Restarting sometimes allows a glimpse of one and then no more. I’m running the standalone version

Running on Linux Mint 20, details are:
Kernel: 5.4.0-59-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 wm: muffin dm: LightDM Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal

Buttons appear to work normally, but hard to tell as I can’t load an image to check.

Any suggestions welcomed, including the blindingly obvious I may have missed.

Regards

Andrew

Hi Andrew,
Sorry to hear, unfortunately, I can’t really say the reason. I will try to check later today for more but it was compiled on Ubuntu, 64bit, version 18.04.5 LTS, which is different from yours. I am not working with Linux myself, but I may expect that the different distributions may not be completely compatible with each other.
Best regards,
Ilya

Hey Ilya,

I am also grateful, the standalone for Windows works very well (minor errors when memory reaches its limitations).

However, I tried to use the standalone version for Linux under Ubuntu 20.04.2 with GNOME 3.36.8 and I have an issue similar to the aforementioned one.
As indicated in the readme file, I use the following command to start MIB:

/run_MIB.sh ../MATLAB/MATLAB_runtime/v97/

MIB starts indeed, I can see the main window and press some buttons, but nothing actually works (e.g. main menus do not drop down). In the command tab, I have the following messages:

------------------------------------------
Setting up environment variables
---
LD_LIBRARY_PATH is .:../MATLAB/MATLAB_runtime/v97//runtime/glnxa64:../MATLAB/MATLAB_runtime/v97//bin/glnxa64:../MATLAB/MATLAB_runtime/v97//sys/os/glnxa64:../MATLAB/MATLAB_runtime/v97//sys/opengl/lib/glnxa64
MIB installation path: <my_path>/application
MIB: adding "<my_path>/application/jars/mij.jar" to Matlab java path
MIB: adding "<my_path>/application/jars/ImageSelection" to Matlab java path
MIB: adding "<my_path>/application/jars/MLDropTarget" to Matlab java path
MIB: adding "<my_path>/application/jars/xlwrite" to Matlab java path
Drag and drop of files to the Image View panel: ENABLED
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:<my_path>/MATLAB/MATLAB_runtime/v97/java/jarext/slf4j/slf4j-log4j12.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:<my_path>/.mcrCache9.7/MIB_3B0/MIB/ImportExportTools/BioFormats/bioformats_package.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.

(MIB:114254): GLib-GObject-WARNING **: 14:28:17.817: cannot register existing type 'GtkRcStyle'

(MIB:114254): GLib-CRITICAL **: 14:28:17.817: g_once_init_leave: assertion 'result != 0' failed

(MIB:114254): GLib-GObject-CRITICAL **: 14:28:17.817: g_type_register_dynamic: assertion 'parent_type > 0' failed

(MIB:114254): GLib-GObject-CRITICAL **: 14:28:17.817: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
signal 11 occured at 0
Native function stack data: 00000000,00000000,00000002,00000000,00000000,00000000,3c0468e0,00007fca,00000000,00000000,00000000,00000000,00000040,00000000,00000035,00000000,0001001b,15b9f9ef,6f6d654d,69207972,6f6e2073,6c612074,61636f6c,20646574,3c746579,00007fca,00000035,00000000,0001001b,7f819a4f,6f6d654d,69207972,6c612073,64616572,6c612079,61636f6c,6c646574,706f6269,00000025,00000000,59454b58,52414f42,00000044,00000000,00000020,00000000,00000165,00000000
Exception in thread "XPCOMMessageLoop": com.jniwrapper.FunctionExecutionException: 34613931
	at com.jniwrapper.Function.invokeCFunc(Native Method)
	at com.jniwrapper.FunctionCall.a(SourceFile:127)
	at com.jniwrapper.FunctionCall.call(SourceFile:35)
	at com.jniwrapper.Function.invoke(SourceFile:188)
	at com.teamdev.jxbrowser.gecko.xpcom.impl.linux.GtkLib.b(Unknown Source)
	at com.teamdev.jxbrowser.gecko.xpcom.impl.linux.LinuxMozillaToolkit.d(Unknown Source)
	at com.teamdev.jxbrowser.gecko.xpcom.impl.linux.LinuxMozillaToolkit.a(Unknown Source)
	at com.teamdev.jxbrowser.gecko.xpcom.MozillaToolkit.initialize(Unknown Source)
	at com.teamdev.jxbrowser.gecko.xpcom.AppShellXPCOMThread$b.run(Unknown Source)

Additional informations:

  • After looking on the internet, some have a similare issue using pyqt and solve it by changing one parameter in Qt .conf file from gtk2 to gtk3 [link: PYQT similar error ].
  • I have gtk3 installed on this Linux and also a gtk2 version (seemingly required to run apps that do not yet use gtk3)

Please do not hesitate to ask for more details, I would really appreciate using MIB on that computer, all the more since the DeepMIB tool is a great addition to the software! Thanks for your help.

Regards

Benjamin

Hi Benjamin,
it is quite hard for me to fix as I only have access to our Linux virtual machine, where everything works fine.
I found one suggestion about the cause of the problem, could you try this build:
https://www.mv.helsinki.fi/home/ibelev/temp/MIB/MIB2_Linux_2703.zip

Iyla

1 Like

Hi Ilya,

Thank you very much for the help.
Unfortunately I do not exactly get what I have to do… I tried to unzip the bundle.zip file and to download the link in installAgentURL.txt, then run the install file but I get the following error message from the matlab installer:

There are no products available to install from this location. You may need to download the appropriate products from our website (www.mathworks.com).

So I tried to retrieve the Matlab/v97 folder from the original Linux standalone version and use it with your custom bundle folder. But I get the same error as I mentionned two days ago.

Am I doing things wrong?

I take that opportunity to ask a few questions on MIB, since it runs really well under Windows and is a great help to me:

  • One cannot load .tif files larger than ~4Gb in MIB. Is that limit fixed, or is it environment-dependant?
  • Some others segmentation development teams started a deeplearning model zoo (bioimage.io). Do you plan to join that zoo as a partner?

Thank you again for all the work!!
DeepMIB is a real time-saver for my projects.

Benjamin

I will try to check that later on our Linux VM. But I am unfortunately not Linux person :frowning:

  • One cannot load .tif files larger than ~4Gb in MIB. Is that limit fixed, or is it environment-dependant?

In my understanding standard TIFs have 32-bit pointers to address data within the files. Thus, max value you can reach is ~2^32 ~ 4Gb. The funny part that Matlab can save files of larger sizes, but it can not read them back.
If you want to work with larger files, you need to use a different format or save files as stacks. I personally keep everything in AM, as it is fast to load and works fine with multichannel LM images and compatible with Fiji. Alternatively, you can try NRRD, or H5 with XML header. MRC should also work, but it is quite a bit slower to read/write.

Some others segmentation development teams started a deeplearning model zoo
I was thinking about that, the problem is time and at the zoo they have some specific requirements on the format… It is possible to export the trained model in ONNX format that should somehow be compatible with other deep learning frameworks. But I have not dived into that yet.
I more interested now in port of MIB into Python and it takes most of available time.

1 Like