Memory Configuration

Hi,

We’re seeing some Blitz out of memory errors in our logs. We are currently using the default memory configuration but as its a dedicated server would it be more sensible to set omero.jvmcfg.percent.blitz to 50? Could we get away with cranking up the percentages for omero.jvmcfg.percent.pixeldata and omero.jvmcfg.percent.indexer at the same time? Any advice much appreciated.

Thanks,

Matt.

Hi @mattc. Welcome to image.sc!

Blitz can typically make use of quite a bit of memory. 64 GB is not unheard of. To really go beyond that, you’ll may want to also look into other Java VM optimizations around garbage collection, etc.

PixelData can also make use of a good deal of memory, but is really only necessary if you are working with large 2D planes, i.e. that you have images that are on the order of 10k x 10k or larger.

The Indexer typically does not need a lot more memory.

Cheers,
~Josh

Thanks @joshmoore, thats good to know.

Hi @joshmoore,

we’ve updated our jvmcfg and we can see that the values have changed accordingly:

JVM Settings:

blitz=-Xmx4101m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions # Settings({‘percent’: ‘50’, ‘strategy’: ‘percent’})
indexer=-Xmx820m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘percent’})
pixeldata=-Xmx1230m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘percent’})
repository=-Xmx820m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘percent’})

Does it matter that the MaxPermSize is still 1g?

Cheers,

Matt.

No. “Starting with Java 8, both the permgen space and this setting are gone.” This option is there for backwards compatibility and will be removed in a future version.

~Josh