i have modules set up to:


It runs fine, the cycle ends with the image and the pixel count below it. however, if i try to export the output *.mat file afterwards, i get an error message:

Error using ==> ExportData>WriteMeasurements
Error in handles.Measurements structure. The field
AreaOccupied_CellStainFeatures does not have an associated measurement field.

i’m not sure what i need to do? worst case scenario is to manually input the value i read off of the image, but i’d rather have the output file.
thanks for any help


I’ve tried a similar pipeline here and exporting the data works fine. I wonder whether you allowed the analysis to complete its cycle (i.e., does the Timer say ‘Image processing complete’)? If it did complete, then there is definitely a problem - would you please let us know the details of your pipeline by doing this:
File > Save Pipeline. Give it a new name, and when it asks if you also want to save it as text, say YES and save as a text file. Then you can open the text file and post it here and we can help.

If you have already figured out the problem, please do post what you discovered here in case others have similar problems.

As an aside, you probably do not really mean to have ApplyThreshold in addition to MeasureImageAreaOccupied? MeasureImageAreaOccupied already applies a threshold within the module itself, so probably you didn’t really mean to have them both together.



i still have the problem where i can’t export the data. the program runs just fine. the output files are produced. the measure part of the pipeline even produces the intermediate figure, which displays the data i want. the pipeline, saved as text, is:

Pixel Size: 1


Module #1: LoadImages revision - 1

i apply the measure module to the thresholded image.
i have cells stained with connexins and nuclei. i want to separate the colors, threshold the connexins, identify the nuclei, measure the area occupied by the connexins. this way i can have a connexins-nuclei ratio.
as of now, i need to save the images and do further count analysis in imagej because the measure portion of the pipeline won’t export.
thanks for any help and comments!


because the subject of measuring a pre-thresholded figure came up, i ran a simple pipeline:


it ran, but again the exporting of the .mat file to excel produced the same error message:

Error using ==> ExportDate>WriteMeasurements
Error in handles.Measurements structure. The field
AreaOccupied_CellStainFeatures does not have an associated measurement



Let’s try one more thing:
We have just released a new version on Wednesday March 22nd. Would you please download and run again? It sounds like you are working with an old version of CellProfiler.

Please keep us posted whether this fixes the problem!


yes, the updated version fixed the problem. thanks very much!