Measure object size shape error

Hi,

Using Cell Profiler 2.1.1 (rev6c2d896) we get irregularly an error message in MeasureObjectSizeShape. However, now the errors start coming more frequently and we have no idea what is causing the errors. We have tried to export the original data (nis files) to tiffs again, to run the analysis on different computers, to run with only one core and with minimized pipeline steps. Nothing has an effect. Only removing the MeasureObjectSizeShape module works, but we need it for our data analysis.

The images are tiffs and we do not see something different in these images compared to others in the dataset.

The error message reads:

Traceback (most recent call last):
File “cellprofiler\pipeline.pyc”, line 1934, in run_image_set
File “cellprofiler\modules\measureobjectsizeshape.pyc”, line 300, in run
File “cellprofiler\modules\measureobjectsizeshape.pyc”, line 370, in run_on_objects
File “cellprofiler\cpmath\cpmorphology.pyc”, line 2390, in calculate_solidity
File “cellprofiler\cpmath\cpmorphology.pyc”, line 2292, in calculate_convex_hull_areas
IndexError: index 2 out of bounds 0<=index<2

I see there is a forum post with a similar topic (Error message for measuring object size and shape Postby elinlundin » Fri Nov 28, 2014 3:03 pm ), but we’ve run many datasets with the same characteristics (almost no staining) without any errors and we use the newest Cell Profiler release. We hope you can help us to find something that is causing this error.

Many thanks,
Steven and Suzanna








201509002 - noWMC.cpproj (900 KB)

Hi Steven and Suzanna,

This looks to be the same error, that we fixed recently:
github.com/CellProfiler/CellPro … ssues/1412

Would you try downloading and running our newest “trunk build” which should have the fix you need?
cellprofiler.org/cgi-bin/trunk_build.cgi

Thanks,
David

P.S. Glancing at the code, this error would depend on the specifics of a particular object’s segmentation within each image. So I could definitely see that it might only be a sporadic crash event, and a new data set might have characteristics that make this more frequent. Hopefully the trunk build works, in any case!

Dear David,
thanks a lot for your quick solution. We are currently testing the trunk build, hope it will work!
Suzanna