Measure Object Neighbors Error

Hi, please see below for an error on measuring neighbors:


project here:
cp3_foxP3_CD4.cpproj (1.3 MB)


Looks similar to something I saw in v2:

Am I just using this module wrong?


You’re not using it wrong, it’s just a bug that sadly has not been fixed yet- you can still measure the closest A->A and B->B, but not yet the closest A->B. I’ve bumped the bug report with your note that it’s still an issue in 3.0; hopefully now with the 3.0 release behind us bugfixes like this can get prioritized!

Very strange. This issue has gone away.
I changed:

  • method to adjacent - still errored
  • selected a different neighbor object with >0 objects (had selected a neg image on the first run) - no error
  • selected another image set, set back to the neg image with 0 objects - no error
  • set method back to specified distance - no error

Fixed, but why I don’t know :frowning:

Hmm, that’s odd- can you post your pipeline, your description, and enough images to reproduce here at the bug report? That way you can directly connect with our engineers, who may have more questions or things for you to test.

Beth, thanks for the update.

Also, I spoke too soon. I changed it back to a >0 object and it errored again :frowning:

I’ll see about using the images and get something online soon.


Hi bcimini,

I have the exact same problem than nranthnoy.
I downloaded 3.0.0, but the bug still exists.
How can I circumvent the problem?

Thanks, Larissa

Can you upload a pipeline and a set of images that reproduce this issue either here or on the bug report? I’ve pinged our engineers on it again.

This thread has some workaround options- this is my personal favorite but YMMV.

012618 JUNC_DV.cppipe (15.8 KB)

Hi bcimini,

Here is the pipeline and a set of images.

Ill look into the thread.

Thanks for the quick response, Larissa

Ok I dont understand why it does not upload the images

Hi all,

Is anybody still looking into that issue? I tried with some of the other suggestions, but nor the morph, nor the expanding is really working for my question.

@bcimini: I tired to upload the images, but for some reason even if the format is correct, they do not appear, any change to send them by email?

Thanks, Larissa

I’ve brought it to the engineers’ attention, but it’s not the only bug on their to-do list so I can’t promise if or when it’ll get addressed.

What specifically is your question? The expand solution, while inelegant, should work for all use cases I’m aware of but perhaps yours is different.

Please either zip the images then upload or upload them to a site like GoogleDrive or Dropbox and post the link here.

Ok here is the link to the images
And this is the updated pipeline (since in the previous I actually reset the objects such that it does not give an error)
013018 STIM_DV.cppipe (15.8 KB)

I wanna now the distance of the nearest object B to each A. But it is different for each object and there are many objects (the image I am sending is just a small inset), and I don’t know the distances at all. With the neighbor I will immediately get the right answer. With the expanding technique I will need to test expanding by 1,2,3,4,5,6,7, pixel etc. exclude each time those that have found the nearest neighbor, a very lengthy process… plus it will never give me the information so exact than the nearest neighbor.

Is there any way I can change object A and B, because in one direction it is working and in the other one it is not?

Best, Larissa

This bug is corrected in version 3.1.5, from B to A is working now, I used the module few days ago.

1 Like

Hmm. I am using 3.1.8 and I get the same error. It reads:

“boolean index did not match indexed array along dimension 1; dimension is 179 but corresponding boolean dimension is 184”

A->B and B->A both return the error and it doesn’t seem to matter which method I use.