Maven.scijava.org 500 error when requesting fiji.sc:legacy-imglib1:2.0.0-SNAPSHOT

Orbit has a dependency on the following library (legacy-imglib1:2.0.0-SNAPSHOT) which this morning stopped resolving:

Could not resolve sc.fiji:legacy-imglib1:2.0.0-SNAPSHOT.
Required by:
project :orbit-image-analysis-os
Could not resolve sc.fiji:legacy-imglib1:2.0.0-SNAPSHOT.
Unable to load Maven meta-data from https://maven.scijava.org/content/repositories/snapshots/sc/fiji/legacy-imglib1/2.0.0-SNAPSHOT/maven-metadata.xml.
Could not HEAD ‘https://maven.scijava.org/content/repositories/snapshots/sc/fiji/legacy-imglib1/2.0.0-SNAPSHOT/maven-metadata.xml’. Received status code 500 from server: Server Error

The same error is visible from the repository browser:
https://maven.scijava.org/#nexus-search;quick~imglib1
Server throws a 500 error.

New to the community, so not sure if this is the correct place to report the issue. Let me know if you need any more information.

As far as I can tell, this is a (temporary) server issue that is known to @ctrueden and @turekg, and they’re working on resolving it.

1 Like

Thanks for confirming Jan!

By the way: is there a reason to depend on the SNAPSHOT version? I’d recommend 1.1.9 otherwise, the latest release version :slightly_smiling_face:.

It seems the issue is solved now; at least I don’t get an error with the repo browser. @jfkotw can you confirm?

1 Like

Confirmed. Works for me now.

I need to follow up with @mstritt on whether it is possible to use the 1.1.9 release.

Thanks for your help.

Yes, @hinerm and I resolved the issue, which was that the maven.scijava.org machine had run out of disk space due to some temporary files during server migration efforts. We are taking steps to prevent this scenario in future.

Please continue to report any issues with maven.scijava.org here on the forum. Thanks!

@jfkotw I would be very surprised if the release version doesn’t work for you. @mstritt If it doesn’t work, please let us know and we’ll resolve the issue. SNAPSHOTs should never be used in production—only transiently during active development.

Agreed! I just tested the build using the 1.1.9 release and all tests are passing, so the next release will use the stable version (which makes me happy). Thanks for the tip @imagejan and @ctrueden.

4 Likes