Manual Tracking Plugin - Unable to load previous tracks

tracking
imagej
plugin
bug

#1

I got this question from a colleague today.

“I have a question about the Manual Tracking plugin in FIJI. I can add tracks and save them correctly. However, I don’t seem to be able to load previous track files. When I try to load a previous track file, all the values for all columns in the results show up as 0. These files are saved as .csv files and when I open them in excel still have the actual data. Do you know why this is happening or have any suggestions to try and resolve this problem?”

I have Fiji with ImageJ 1.51s. I tried creating a dummy dataset with the MRI Stack sample and got the same results (file has 0s when loaded through plugin but all data is there when opened in Excel). Updating did not solve the problem. Is this a bug?

Thanks!
Christine


#2

Dear @clabno,

That’s very likely. Which operating system are you/your colleague running? Also, what’s the system language on your computers?

Could you upload the CSV from that example?

Best,
Stefan


#3

Hi Stefan,

I’ve tried Windows 7 and Mac OSX El Capitan both running Java 8 and gotten the same results from both. All of the values are intact in Excel but import as 0s into Manual Tracker.

The forum won’t let me upload a .zip file of the .csv, it says I’m too new here. Here is a link to the csv on Google Drive

https://drive.google.com/open?id=1dAvT8Fa-Wi_H0zz7RM_1Pbdc3sP_fNDD

I created a dummy file with three tracks using the first channel / slice of the mitosis sample image.

Thanks!
Christine


#4

FWIW, I manually increased your user trust level just now, so this shouldn’t be a problem in the future.


#5

Here is the same csv as a zip fileResults from mitosis-1 in µm per sec.zip (1.6 KB)


#6

The file looks good to me (as it does to Excel). Still, what’s your computer’s system language? If it’s not English, is it a language that has , as decimal separator, by chance?


#7

The system language is English and the decimal is the decimal separator.


#8

Although that did give me an idea. When I change the data table saving format to .tsv Manual Tracker can read saved track data. So it’s maybe not a bug, just a difference in format preferences between languages.

Thanks!
Christine