Macro set installation issues

I tried to run the following sample macro set in Editor window, but it just stopped at the end of the first macro… Then
I tried to install it (in Fuji) but failed. I thought I followed the instruction but I never get it on the menu. I just can’t figure out why this happened. Can anybody there help me out? Thank you. Steven

var s = “a string”;

macro "Enter String..." {
    s = getString("Enter a String:", s);
}

macro "Print String" {
    print("s=" + s);
}

In my case it didn’t work out as well when I tried to run it after I’ve written the script in the editor. But after I’ve saved the script on my desktop it worked fine. So try to save the script and run it again. Hope that will work out.

Thanks. But I just tried a different way, once the set has been installed, the macros show in the menu right away, no need to restart.

Unlike the ImageJ macro editor, the Fiji Script Editor does not have a command to install macro sets. You can work around this limitation by using the Plugins>Macros>Install command, which installs the macros contained in the macro set at the bottom of the Plugins>Macros menu.