Mac OSX Cell Profiler 2.0 Analyze Error

We are currently running v9722 on Mac OS 10.6 and are unable to actually analyze our images. We have successfully created a pipeline and have run it in test mode without issue, but when we go to analyze our complete data set, instead of the normal timer window we get a blank window and absolutely nothing happens, no matter how long we leave the program running. We have run the exact same pipeline and images through the alpha version v9336 without issue.

Attached is the pipeline we using and one set of images.
images and pipeline.zip (1.3 MB)

Dear cell profiler staff,

I have the same problem on my mac os x 10.6,

thanks,

Francesca

How large a set of images are you trying to analyze? The blank screen may be CellProfiler finding every image and figuring out how to group them into image sets.

Could you also start Console.app, select “All Messages”, and Filter for “CellProfiler”? That should show some debugging information. If so, could you post that here?

Finally, when you force CellProfiler to quit, does it offer to send a problem report? The information in that dialog might be useful to diagnose this problem, but you’ll have to copy it to the clipboard since that dialog sends the report to Apple by default.

Thanks,
Thouis Jones

The set of images I am attempting to run is not very large (a little over 50 images).

When I quit CellProfiler it does not offer to send a problem report.

Here is the debugging information you requested

4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] Starting VM
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] VM started
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] Subversion revision: 9722
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] Pipeline saved with CellProfiler SVN revision 9722
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] Traceback (most recent call last):
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “/Users/thouis/CPVENV_254/CellProfiler/cellprofiler/gui/pipelinecontroller.py”, line 630, in on_analyze_images
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “/Users/thouis/CPVENV_254/CellProfiler/cellprofiler/gui/progress.py”, line 45, in init
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “AppKit/init.pyc”, line 10, in
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “Foundation/init.pyc”, line 10, in
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “CoreFoundation/init.pyc”, line 17, in
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “objc/_bridgesupport.pyc”, line 129, in initFrameworkWrapper
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] File “objc/_bridgesupport.pyc”, line 53, in _parseBridgeSupport
4/8/10 9:46:34 AM [0x0-0x67067].org.pythonmac.unspecified.CellProfiler2.0[1727] ValueError: Unknown typestr

Our local IT people who have created a cluster version of CP believe it might have something to do with Python and Snow Leopard.

Let me know if you need any more information.

Heather

Thanks for the report. I think I have a handle on what is wrong. We will be releasing a new version of the beta soon, hopefully with a fix for this (and other issues).

Hi Thouis,
With my MacOs X 10.6 laptop, I have the same problem when i analyze the 3 images of the Human HT29 cells example, available on the cell profiler web-site.
What can i do?
Thanks,

Francesca

I’m going to try to build a fixed version this afternoon. I might ask for your help in testing it. I have limited access to Snow Leopard machines at this time, unfortunately.

I have a candidate that should fix this problem: http://www.broadinstitute.org/~thouis/CP_2.0_Beta_r9755.dmg

Could you download and see if it addresses the crash you are seeing? Note that the title bar will still say 9722.

We’re working on a few other changes for the Windows build, so this isn’t the official second Beta, but that one should be ready soon.

EDIT: I was able to reproduce the bug on my home machine, and verify that the new version fixes it. Sorry we didn’t catch this before.

Thanks Thouis,

this version of cell profiler 2.0 works! thanks for your help,

Francesca

Worked well for me as well, thank you for the fast turn around time.

Heather