LUMoS spectral Unmixing plugin on Mac OSX

Trying to run the LUMoS Spectral unmixing plugin under an updated Fiji on Mac OS 10.13.6: several dependencies were not included in the distribution:

  • nd4j-native-platform-1.0.0-beta3.jar
  • nd4j-native-1.0.0-beta3-macosx-x86_64.jar

After adding these two and restarting Fiji there is still an UnsatisfiedLinkError:

Caused by: java.lang.UnsatisfiedLinkError: /Users/nico/.javacpp/cache/nd4j-native-1.0.0-beta3-macosx-x86_64.jar/org/nd4j/nativeblas/macosx-x86_64/libjnind4jcpu.dylib: dlopen(/Users/nico/.javacpp/cache/nd4j-native-1.0.0-beta3-macosx-x86_64.jar/org/nd4j/nativeblas/macosx-x86_64/libjnind4jcpu.dylib, 1): Library not loaded: @rpath/libmkldnn.0.dylib
  Referenced from: /Users/nico/.javacpp/cache/nd4j-native-1.0.0-beta3-macosx-x86_64.jar/org/nd4j/nativeblas/macosx-x86_64/./libnd4jcpu.dylib
  Reason: image not found
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)

It looks like the .dylib libraries are not seen by the loadLibrary function. I tried copying the dylib libraries from the nd4 cache into Fiji.app/lib/macosx, but that also does not seem to work.

Anyone any ideas how to package this so that it works out of the box?

I didn’t have the chance to try out #lumos yet, but for what it’s worth, I invited the authors of the plugin (and this publication) to this topic (using the :link: Share button).

Let’s see if they’ll be able to help.

Hi, nicost,

We are currently working on this issue. The original Plugin was developed and tested on windows system, so we didn’t find this issue on Mac. We will get back to you soon when we fix the issue. In the mean time, if possible, please use a windows computer to run the plugin. Thank you for your interest to use our algorithm.

1 Like

The plugin has now been updated to include Mac specific dependencies and will now run on OSX after updating. Thanks for bringing this to our attention!

Hello
I tried to install Lumos on FIJI running in Mac but it makes FIJI crash.
I installed it by the update site but after that FIJI does not reopen.
I had to download FIJI again and reinstall all my plugin the only one that gave me problem was LUMOS.
Maybe , there is still something that is not compatible with Mac

Greetings

FWIW I had the same thing happen to me with Fiji on Windows. I did get it to launch by downloading the complete fiji/LUMOS windows package from the imageJ plugin page, but this then seems to run into errors during execution: ConvergenceException: Illegal state: empty cluster in k-means
It seems to be a java version incompatibility so perhaps there’s a special constellation of Java, CUDA, ImageJ that works, but whatever I got certainly ain’t it. If anyone does have this plugin working and is willing to share: exact windows/java/cuda/imageJ versions and anything else that you think might be relevant?

2 Likes

Related topic here: LUMoS update site breaks Fiji after August 2020 update
There is a link to download Fiji with LUMoS already installed. Just make sure you don’t update ImageJ or any plugins or that will break it again. I have been using this separately from my “normal” updated version of Fiji, and it seems to be working.

1 Like