LUMoS Spectral Unmixing (ImageJ/Fiji)

Hi All,

I am acquiring images using the Nuance mutispectra system. With this (old) software I can manually calculate the spectra, unmix and calculate the area of localization as well. However I can’t have a batch processing mode.

I searched the multispectra plugins for ImageJ and found this one “LUMoS Spectral Unmixing (ImageJ/Fiji)”.
However, I can’t find the .jar file to put on my plugin folder in ImageJ. I tried to follow the instructions using the updater but
without success since I can not find the updater in ImageJ:

I am using Mac OS 10.14.6 and the last version of ImageJ

Can someone help with this or suggest me a plug in to use for multispectra imaging and unmixing that I can use in a batch processing mode for multiple images?

Thank you very much for any help,
Simone

Hi @sdegan
Welcome to the forum
and
welcome to the ImageJ / FIJI universe.

The plugin you are looking for is not designed to be used in ImageJ.
It is a FIJI plugin!

To use the LUMoS Spectral Unmixing plugin download and install FIJI (https://imagej.net/Fiji/Downloads).
Then use the updater in FIJI (in FIJI use Help>Update…).

If you are new to the IJ/FIJI world it can be at least a little confusing that ImageJ and FIJI are very related on one side but are very different on the other.

This confusion is enhanced for newbies when in information (like https://imagej.net/ImageJ_Updater and many others) the expression ImageJ is used even if it is clearly and strictly targeted to the FIJI app.
For a newcomer as you this little but dramatic difference is not noticable.
Sorry for that.

Hi,
I have followed the procedure and also Help. Update and installed the LUMoS Spectral Unmixing (ImageJ/Fiji). However, Fiji crashed (does not launch) after the installation. It works well prior plugin installation. I have tried three time a fresh install but same behavior.
The he Fiji logo comes up then nothing happens and it disappear.
Same problem that I found here:

Any suggestion?

PS my understanding is that ImageJ and Fiji are the same thing. Should I keep ImageJ as well in the machine?

Thank you

No worries. If you have Fiji, you have ImageJ (but not the other way around), as Fiji bundles both ImageJ1 and ImageJ2.

… and to be nit-picky, this is actually the official ImageJ updater. Part of ImageJ2 and therefore also included in Fiji. But there’s nothing Fiji-specific about the updater.

But I agree, it’s confusing, unfortunately.


Now back to the actual issue:

This is a know problem, please see this post:

I mentioned @tristan_mcrae (the plugin maintainer) already, but I don’t think the situation has changed since then.

The easiest workaround for now is to download an older version of Fiji with LUMoS pre-installed, as mentioned in the linked topic.

I have switched to a pc since I have tried so many times in a Mac OSX and Fiji is not starting. I have downloaded the version of Fiji that includes the LUMoS plug in. However, I am confused.
As soon as I go to plug in and LUMos I have a popup window saying “A data set is required but none exists”.
I read the instructions and I should have a different popup:


![Screen Shot 2020-10-22 at 3.21.31 PM|690x260]

Thank you

Did you open an image before starting the plugin?

Yes, if I open any image. The problem is how to open a multispectra image acquired with the Nuance multispectra image system that has different extension. The idea is to get the file from the Nuance and the file of the calculated spectra for the channel of interest and do a batch processing with Fiji ImageJ.
If this is not possible what kind of images should I have for the spectra unmix LUMoS? Is just a bright field photomicrograph fine with this?
Thank you

@sdegan

From (https://www.urmc.rochester.edu/MediaLibraries/URMCMedia/multiphoton-core/documents/Spectral-Unmixing-FIJI-Plugin-User-Guide_4.pdf):

“LUMoS spectral unmixing is a blind spectral unmixing tool. No fluorophore spectrum information is needed.”

What kind of images do you have? Fluorescence or transmitted light images?