Loading stack flex files from Opera

Hi,
I am struggling with getting CellProfiler understand the images that were acquired using OPERA software. The filenames look as following: 00X00Y00Z.flex, where X=raw #, Y=column #, Z=FOV #. I have no problem extracting this positional information. However, each file is a stack containing 5 images taken from different channels. I assume that info should be in the headers, but when I tried extracting metadata from image headers, the results don’t seem to make sense (does not detect multiple channels).
Note that I can open the flex file in ImageJ and it opens normally, as a stack with 5 images in it, so the file is not corrupt.

Hi,

Can you upload a file so that we can verify the behavior? I know you usually can’t on your first forum post.

Also, can you try removing your images from the pipeline, reloading them (or at least one or two you know aren’t corrupted), hitting the “Update Metadata” button FIRST, then the “Update” button, as demo’ed in the forum post below?

yes, I have tried all those suggestions. Unfortunately, with the same result. I have uploaded a zipped flex file (make sure to unzip first). Thank you so much for your help! I really appreciate it! 001001001.zip (1.5 MB)

Hi @Natalie_Prigozhina,
@bcimini
I downloaded you image & unzip it. I tried in Fiji to open your image using Bio-formats to check your metadata info. But I couldn’t open the image or metadata. This is the error,

Also, tried with the Cellprofiler, as you had mentioned in the thread which is not successful again & I resulted in the following. I think there is a problem with the meta data atleast with the file you have shared.
Have you tried opening these images in Fiji, if so how?
With CP, while extracting metadata it detects only the Well info, but nothing else. This is what I get it with Cellprofiler,


I am not sure if file format is the issue.

Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
For CellProfiler training or optimised pipeline write to,
lakshmi.balasubramanian.contractor@fujifilm.com

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

Join us at, https://www.slas2020.org

I originally could not open your file in CellProfiler OR FIJI, until I updated my FIJI; then it worked.

That says to me that your files need a really current version of BioFormats to load- probably more up to date than the current version of CellProfiler contains.

You’ll either have to build python-bioformats and CellProfiler from source so you can pull an updated version of BioFormats, or wait until the next release of CellProfiler, since we’ll certainly update BioFormats in the next release. That may not be for 2-3 months though.

Sorry!

Dear Lakshmi and Beth,
thank you so much for trying to figure out my issue.
I was able to open the files with the latest version of ImageJ without any complications. As you can see, it loads as a stack of 5 planes:

We are using an old Opera 2.0 and I would be very surprised if they are some very new format. Is it possible that I might actually have more success with an older version of CP? Many thanks!

No, I tried an older version of CellProfiler, no dice. BioFormats most recent release (in June) changed handling of FLEX files; even if your microscope is old, if it had a recent-ish software upgrade the software may have changed such that you need the new release to read them.

Apologies! You can also try seeing if your microscope can export the images as tifs rather than .flex files, but unfortunately other than waiting or building from source there’s not much else I can recommend at this time.

many thanks for your help and the explanation!