LoadImages question

Hi there,

I’m running CP 10415 on a Mac and try to load images of the following file structure:

— Hoechst_ND_50%B - n000000.tif
— Hoechst_ND_50%B - n000001.tif
— GFP_ND_50%B - n000000.tif
— GFP_ND_50%B - n000001.tif
— mKate_ND_50%B - n000000.tif
— mKate_ND_50%B - n000001.tif

The images are 16 bit grayscale images. Running the module everything seems to be fine. Even the “Choose image cycle” shows nicely that for each cycle the three corresponding images are recognized. But when I add a RescaleIntensity module for one channel it looks like there are multiple channels withing one image… Am I doing anything wrong?
I need to work with this older version because I then can use our cluster to run the pipeline later.

example.cp (2.41 KB)

Problem solved.
I’ve been told that it generates problems if there are other files in the directories beside the one I try to load (though they do not match the pattern).
So removing all other files should solve the problem.


Hi Antje,

Hmm, you really shouldn’t need to remove all other files to get this to work. I’m glad you seemed to have solved the problem, but just a few thoughts:
(1) Do you really need the RescaleIntensity module? The option in LoadImages called “Rescale intensities” usually does the same 12-16 bit rescaling.
(2) Are you sure that these are really single page tifs? Open the image in CP, right-click on the window: Does it list a “Channels” selection in the drop-down?
(3) I’d be curious to try using the “Exact match” file selection method in LoadImages. It seems like this simpler method would work and might uncover a regular expression bug.


Hi David,

thanks a lot for your answer. To answer your questions:

(1) The “rescale” option is not available in CP 10415
(2) No, I’m not sure that these images a single page tifs. CP 10415 opens it as three channel color image. The new CP-version opens it as single page tiff. Other software like Fiji also opens it as single page tiff. It should be a single page tiff but I don’t know how to prove.
(3) The “Exact Match” method does not work because there are other images in the folder which start with the same name (e.g. Hoechst_ND_50%B - Graph.bmp). Those files should be excluded. And even if I exclude them by filtering for bmp-images the result stays the same as described above…