Links to public datasets and projects in OMERO.web: auto-login issue

Dear all,

We are running a test phase with OMERO at EPFL (Switzerland), and encounter issues when creating links for public shares.

We have created a public user, named “public public”, which belongs to the group “Public Group”. Inside this Public Group, there are projects and datasets owned by different persons, but not by the “public public” user.

This is the server configuration that we have made:
omero config set omero.web.public.enabled True
omero config set omero.web.public.user ‘username’
omero config set omero.web.public.password ‘password’
omero config set omero.web.public.url_filter ‘^/webgateway’
omero config set omero.web.public.server_id 1

Now, I would like to share direct links to specific datasets or projects to externals, like so:
https://omero.epfl.ch/webclient/?show=project-537
https://omero.epfl.ch/webclient/?show=dataset-766

These links are direct links respectively to a public project and to a public dataset from our server, but unfortunately they are not working: our OMERO server asks for credentials.

However, we know that the configuration of our public user works somehow, because we can connect without credentials to the global webclient view of the public user with this link: https://omero.epfl.ch/webclient/?server=1&bsession=public

And as soon as we are connected with this link as the “public public” user, the first two links are working as well, but it is not really convenient to tell externals to go first to https://omero.epfl.ch/webclient/?server=1&bsession=public and then to https://omero.epfl.ch/webclient/?show=project-537 to be directed to the right project.

How could we make the direct links to project and dataset work?

Thank you very much in advance,

Claire

I think the issue may be due to your url filter? If you want to view the webclient, you need to enable that like

omero.web.public.url_filter=^/webgateway|webclient

1 Like

Thank you very much Dave, changing the url filter succesfully solved our issue!

1 Like