LimeSeg plugin usage: enabling 3D viewer causes FIJI to stop responding in MacOs Mojave

Hello!
I have been trying to run the limeseg plugin to do some 3D spherical segmentation. When I enable the Show3D viewer to show the output, I get a window with the blob, so far so good. But immediately after this FIJI just stops responding and I have to force quit the application. Sometimes I get a blank window titled 3D Display and an error:

createAndCompileShader: Pre GL Error: 0x500

I tried to follow the steps Plugins->Utilities->Debugging and tried Java3D and also launching 3D viewer independently, both work. I have Java-8 enabled and on MacOs Mojave. I tried to find if anyone else has had this issue but could not find anything. Any pointers?

2 Likes

Hello @gayaJ,

So just to be sure, can you try to:

  • Open the script editor (File>New>Text Window)
  • Run the Demo Vesicle Segmentation script (Templates>Lime Seg>DemoVesicleSegmentation (Groovy))

If this hangs and crash, unfortunately there’s not much I can do. It means it’s a hardware+OS specific issue which is very tedious to solve. I’ve had issue specifically with Mac, whereas on Windows and Linux all works fine.

FYI, I also get the error message you mention, but it does not prevent correct display, so it’s probably unrelated.

A goal (long term or medium term), will be to migrate the 3D display of LimeSeg to Sciview, but the schedule is uncertain at the moment.

2 Likes