Latest Fiji update on OSX - problem with memory setting




Tonight there was a big update in Fiji including OSX specific parts (from a glance at the update panel, btw is there a post somewhere describing this?). Once done, my Fiji install was set to ~4.5 GB memory so the first big task I did caused an out of memory error. I set it back to 14 GB (I have 16 GB total on this computer) but the setting is not retained, and when I restart Fiji it is back to 4.5 GB.

Luckily I had a backup version of my install from a week or so ago so I could revert to this. Does anyone else see this problem too?


So after playing update and switch with the previous version, I can confirm that the new ImageJ-osx version in is responsible for this. If I make a full update to the latest Fiji version (Java8 update site) and replace the new ImageJ-osx with the previous one, memory setting is retained again. With the new one, it is reset to ~4.8 GB at each launch, no matter what I set in the options.


To pursue my monolog; the Info.plist in correctly lists the memory setting (14000m in my case) but with the new ImageJ-osx version, it’s not taken into account and invariably starts with a memory setting between 4.7. and 4.9 GB.


hi, @christlet

I just updated and suddenly couldn’t open my files. I have tried to change the memory settings but I face the same problems you did. I do not know the first thing about computers, so needles to say I didn’t understand your comment above about how to fix it. I would be very grateful if you could explain it to me as if I were 5 years old…
2016 mb pro tb, 16gb ram, OSX High Sierra.


Hi christlet, I am having the same problem with Fiji and memory allocation from your experience what is the best solution to solve it.
Thank you so much


Hi christlet, thank you for the hints.
Based your description, this is what we do to fix it:

  1. cp /Applications/ /Applications/
  2. cp /Applications/ /Applications/

Restart Fiji.


This is what I did, hope there will be an official fix for ImageJ-macosx soon


I will try to investigate + reproduce + fix tomorrow.


Thanks Curtis! Let me know if you need any more info


Back to the lab and I have the same problem on the mac there (also under High Sierra, but not APFS as it is a Fusion Drive).

Laptop under High Sierra (APFS) 16 GB RAM: memory stuck at 4.7 GB.
iMac under High Sierra (HFS+), 24 GB RAM: memory stuck at 12.3 GB.

Not sure it depends on the RAM installed or on the initial amount of memory specified at first launch of the new ImageJ-macosx.

@ctrueden did you get a chance to investigate?


I have the exact same problem. Has there been a fix yet?
Would somebody care to describe a work around in “ImageJ/Fiji-newbie language”?

Looking forward for your help.

Kind regards,


I don’t think so.

If I understood @christlet and @larry1 correctly, this should work:

  • Browse to your ./ (by right-clicking on your icon and selecting Show Package Contents)
  • Rename ImageJ-macosx to
  • Rename ImageJ-macosx.old to ImageJ-macosx
  • Run Fiji by double-clicking on your icon

or, from the terminal, as described by @larry1:


THANK you so much, it worked!


Same issue here on MacOS High Sierra, i7 2.93GHz, 12GB RAM > actual ram in Fiji/ImageJ 1.51t stuck at 4325MB.


I am not sure why this bug happens, but I believe I have fixed it:

The old launcher did not have the problem, whereas the new launcher did with both Java 8 and Java 9. (I tested only on High Sierra—but the old launcher still worked on High Sierra.)

I will upload the fix to the Java-8 update site after Travis deploys the new build.
Edit: The fix has been uploaded!