Latest Fiji (rc-69/1.52i) on mac - new install can't update

Hi all,

just did a clean re-install of Fiji on macOS (Mojave).

No problems launching or running, however when I try to update (either update just imagej or full fiji updater) I’m getting and error with no write access to /private/var/folders/t4/…

(this is running from within Fiji Help menu - I haven’t tried the CLI updater…)

When running ImageJ Updater get

“No write access: /private/var/folders/t4/…/T/AppTranslocation/…” (…a random long strings)

When running Fiji updater it searches the repo’s fine, then pops a window up with:

“Warning: The following files are set to read-only: 'jars/… … …”

(ie basically every jar or plugin that it wants to update I presume)

I’m guessing (have no clue what /private/var is used for) Fiji is caching itself into there when it’s running, but then can’t write (I checked - all the directories are read-only file systems inside there - so chmod doesn’t work - already tried that). And update isn’t looking for the original directory (in Fiji.app), but looking in the cache directory…

Anyone else seen this?
Any hope for a fix? (this seems like a packaging for mac issue…)

thanks!

Richard