Label font and size changed

fiji

#1

Hi,

I don’t know when it exactly changed but today I used the particle analysis and the label font and size was different to what I was used to before. I used a simple binary image. Originally the labels were thin and consisting of lines with a 1 pixel width. Now they appear quite bold and large so that they cannot be read anymore if two particles are too close to each other.
I tried to find a solution to change the label style back but nothing worked so far.

I hope someone might know if there is some sort of setting that can be changed or where to change the font and size in the macros. A plugin that labels particles similar to the particle analysis that works would do it as well.

Thanks a lot


#2

You can change the label size in the ROI Manager with the Label option, see:

https://imagej.nih.gov/ij/docs/guide/146-30.html#sub:ROI-Manager

if you add the ROI’s to the ROI Manager (Analyze Particles, option “Add To Manager”)


#3

If i change the font in the ROI manager the labels become smaller but very blurry. But I guess I will do it this way and convert them into a binary image to get rid of the blur.

Thanks


#4

Does the Options>Fonts>Antialiased text option make any difference?


#5

Sadly not.
To what kind of selection does this command apply?
I selected all items in the ROI manager but cannot change the font (e.g. Arial).
Right now I get around this issue by converting the flattened image containing the labels into a binary image. At least the labels are no longer blurry then.


#6

The font tool, I think, so when you burn the text into the pixel data it does antialiasing (or not).
I do not know if the font can be changed (other than the size) in the ROI manager.
I wonder if this is some blurring your display driver is applying, or the OS? In here (linux) the labels are very sharp. I can change the size and colour but they remain sharp.