Issues with Image J Thresholding?

I am trying to perform colour deconvolution, but when I convert myimage to binary, I am unable to manually adjust the threshold to accurately differentiate cell bodies. As soon as I adjust the scale bar the image ether goes completely white or black. The first image is immediately after I make binary, the second when I attempt to adjust threshold.

Has anyone had this issue before? I have tried updating my computer (mac), updating image J, using a previous version of image J, and also trying on my windows PC, to no avail. Any advice would be amazing!

Hey @asorbyadams,

could you please precisely list the steps you are doing? And example image would also be good so that we can reproduce your procedure.

Cheers,
Robert

Do I understand correctly that you are trying to adjust the threshold after binarising your image? If so, your image only has black and white pixels (in your case of an 8-bit file, the values are 0 or 255). If you then try to threshold between 106 and 171, as shown on your second image, you’ll get nothing…

Sincerely,

Matthieu

Hi Robert, Thank you for your response!

I am currently undergoing the following with the attached image:

  1. Open image
  2. Process-Binary-Make Binary
  3. Image-Adjust-Threshold

This is the step I get to where I am unable to move the Max or Min threshold bars to accurately adjust the image threshold.I have not touched any other settings.

Thanks so much again!

The problem you have is that you have binarised before thresholding, which is the wrong order. If you want to -for example- select the brown cells in your image you need to

  1. Open image
  2. Image>Color>Split Channel
  3. Select the grey channel that shows your cells best (blue or green)
  4. Threshold it appropriately and click “Apply”
  5. you now have a binary image where your cells are white and everything else is black.

Sincerely,

M.