Issues Running Sholl Analysis on Simple Neurite Tracer

imagej
segmentation
sholl-analysis
simpleneuritetracer

#1

Hi, new to the Forum. After I complete a tracing of a neuron with Simple Neurite Tracer, I select the innermost soma segment and use Shift+Ctrl+A to try and set a specific point as my center for analysis, but every time I get an error report:

Exception in thread “AWT-EventQueue-0” java.lang.NoSuchMethodError: org.jfree.chart.renderer.xy.XYBarRenderer.setGradientPaintTransformer(Lorg/jfree/ui/GradientPaintTransformer;)V

Followed by about 27 lines of other exceptions.

How do I set a certain section of my tracing as the center for sholl analysis without getting a massive exception report?


Have to revert to version 3.0.2 to get a sholl analysis reading Simple Neurite Tracer
#2

I’ve been having a lot of trouble with the Simple Neurite Tracer Program. I posted about the same issue earlier, but now I have details. I have been following the ImageJ online guide in order to get sholl analysis output from tracings, but it seems that no matter what version I’ve been using, I always end up with this same error report.

I’ve gone through and tested versions 3.0.2, 3.03, 3.1.3, 3.1.4, and 3.1.5 to try and resolve the issue, and so far only version 3.0.2 has given me the sholl analysis menu, but it also showed the same error report. The rest of the analysis worked. I want to know if this is a bug of some sort or user error, because I haven’t been able to find anything on the website.


#3

I haven’t been able to reproduce your issue with an up-to-date Fiji installation:

  • Run Analyze > Sholl > Sholl Analysis
  • On the dialog “There are no images open”, click Analyze Sample Image
  • On the following dialog, click OK

I get the following output:

image

image


Do you have any non-default update sites enabled in your installation? Some of these might ship an outdated version of JFreeChart…


#4

The issue comes up when I use the Sholl Analysis function described in the online manual. When I try to use the Shift+Ctrl+A command to set a portion of my trace as the center of analysis, that’s when the error report occurs


#5

Welcome to the forum @David-K, and thanks for the Console snapshot. Really useful. The preview plot of the Sholl Command relies on the jfreechart library that was recently updated. That error is caused by a method on that library that no longer allows un-defined (null) inputs. Why did we missed it?: The change seems to be undocumented, and Simple Neurite Tracer does not have compilation tests to evaluate this kind of bugs. Interesting it does not happen in any of the computers I use, but my setup is likely different from yours. A fix for this should be appearing soon on the updater. You can follow the progress here:


Have to revert to version 3.0.2 to get a sholl analysis reading Simple Neurite Tracer
#6

Hi again,

I’ve downloaded the hot fix for imagej with the updater, and I tried making new tracings and running the same sholl analysis process with the updated Simple Neurite Tracer. The error report still comes up, but there are differences. Here is the new report:

And here I’ve taken the liberty to mark out any differences I spotted while comparing to the last report I got:

You mentioned something about my setup here possibly causing the reports, any idea what kinds of programs could be interfering with the test?


#7

I forgot to mention, the blue portions are new, the black sections are the parts that were found in the previous report as well


#8

@David-K, I have not uploaded anything yet to the Java-8 update site. Please be patient while we address the items in the Github issue mentioned above. The exception you mention now remains the same. You probably just received an update for some other component of Fiji and thought it was SNT. Also, to clarify:

I did not mean that. What I was trying to say is that when I trace cells I use an experimental branch of SNT, thus I’m not fully exposed to all the issues that occur in the official releases of SNT. That’s why bug reports from users like you are important!


Sholl Analysis (Tracings) - Odd Bug
#9

@David-K, SNT version 3.1.6 was just uploaded to the Java-8 update site. You should no longer have this issue, do let us know if otherwise.