Issues installing with conda




I’m trying to install cellprofiler on ubuntu 16.04 by following the instructions here, adding bjornfjohansson to channels, and wxpython= to dependencies in the environment.yaml file.

source activate cellprofiler
I get the error:

Traceback (most recent call last):
  File "/home/scott/anaconda3/envs/cellprofiler/bin/cellprofiler", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 3036, in <module>
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 3020, in _call_aside
    f(*args, **kwargs)
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 3049, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 656, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 669, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'prokaryote==2.3.2' distribution was not found and is required by CellProfiler

Changing that in environment.yaml and trying again I then get as far as:

Traceback (most recent call last):
  File "/home/scott/anaconda3/envs/cellprofiler/bin/cellprofiler", line 11, in <module>
    load_entry_point('CellProfiler==3.0.0', 'console_scripts', 'cellprofiler')()
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 560, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 2648, in load_entry_point
    return ep.load()
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 2302, in load
    return self.resolve()
  File "/home/scott/.local/lib/python2.7/site-packages/pkg_resources/", line 2308, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/home/scott/anaconda3/envs/cellprofiler/lib/python2.7/site-packages/cellprofiler/", line 1, in <module>
    import bioformats.formatreader
  File "/home/scott/anaconda3/envs/cellprofiler/lib/python2.7/site-packages/bioformats/", line 21, in <module>
    import javabridge
  File "/home/scott/anaconda3/envs/cellprofiler/lib/python2.7/site-packages/javabridge/", line 38, in <module>
    from .jutil import start_vm, kill_vm, vm, activate_awt, deactivate_awt
  File "/home/scott/anaconda3/envs/cellprofiler/lib/python2.7/site-packages/javabridge/", line 157, in <module>
    import javabridge._javabridge as _javabridge
ImportError: /home/scott/anaconda3/envs/cellprofiler/lib/python2.7/site-packages/javabridge/ undefined symbol: PyFPE_jbuf

After some googling, I’ve tried uninstalling pip versions and reinstalling conda versions of javabridge/cython/numpy though I still get the same error.

Just wondering if anyone has had this issue before, or any ideas?



We JUST bumped prokaryote versions to 2.3.2 and haven’t had a chance to update the wiki yet- can you try editing that in your yaml and seeing if that helps?


It was buried amongst the tracebacks, but I changed the prokaryote version which led me onto the next more cryptic error message.


I found the solution: despite uninstalling and re-installing the packages it was still using the cached versions which I think had been built with a different version of python(?)

Re-installing with pip and the --no-cache flag on the troublesome packages in the conda environment seems to have fixed it.


Glad you got it working! I’ve updated the wiki with your solution.