Issue with Omero insight admin start

Hi,

After omero insight server installation i cant start the service using “omero admin start”
Here with i attached the screen shot.

Using Omero version

omero/5.6.1/sysadmins/unix/server-debian10-ice36.html

Need help to fix this issue

There could be clues like long stack traces toward the end of Blitz-0.log. Please feel free to paste anything bad-looking from that, or even zip up your OMERO server’s whole var/log/ directory and submit it to http://qa.openmicroscopy.org.uk/qa/upload/ or otherwise make it available and we’ll be happy to take a look through it all.

Thank you for mentioning that you were following https://docs.openmicroscopy.org/omero/5.6.1/sysadmins/unix/server-debian10-ice36.html - for what it’s worth, I think the usual mistake people make there is missing some of the “The following steps are run as …” user switches.

Maybe also let us know after you run settings.env what pip freeze and omero config get look like.

Hi,

I uploaded the log file, kindly have a look and sort the issue

Thanks

Thank you. That looks to be your operating system’s log directory, not the OMERO server’s. You will probably find the OMERO one somewhere like /opt/omero/server/OMERO.server/var/log/.

Sorry,

No i uploaded the new zip file.

Thanks

In the error log there’s a PSQLException: FATAL: password authentication failed for user "omero".
Could you check if you set the correct postgres database password in your omero server config?
If you followed the https://docs.openmicroscopy.org/omero/5.6.2/sysadmins/unix/server-debian10-ice36.html docs then this is the password you specified in the first step as OMERO_DB_PASS=db_password as part of the settings.env.
You could just try to set that again to the correct one with omero config set omero.db.pass THE_PASSWORD (see https://docs.openmicroscopy.org/omero/5.6.2/sysadmins/unix/server-debian10-ice36.html#configuring-omero-server ) and then try to start the server again. Note: That’s the database password, not the omero root password!

Kind Regards,
Dominik

1 Like

Hi, the password is correct , i tried login with password directly it works good.
Can you assist via team viewer or anydesk ? If possible ? its in private IP.

Thanks

Hi! Could you please tell us how what method you used to verify the password, as some postgres auth combinations allow you to login without a password.

Could you run

PGPASSWORD=<your-password> psql -hlocalhost -Uomero -l

and show us the output? Thanks!

Hi
Output for the given command


Kindly check the screenshot

Hi @vsnlme108,

thanks for checking that. What user are you during that call? postgres? Can you show us the output of omero config get | grep omero.db ? Do the values match? I would expect:

omero.db.host=localhost    # or omitted since this is the default
omero.db.name=omero        # or omitted since this is the default
omero.db.pass=******       # of course a secret
omero.db.user=postgres     # or whatever user you used above

~Josh

The output is given below

omero config get | grep omero.db
sh: 1: omero: not found

Hi @vsnlme108,

in Issue with Omero insight admin start it looks like you used:

su omero-server
. ~/settings.env

in order to run omero. You will need to do that here as well.

Also, which user did you use to run psql?

~Josh