Issue with Integrated Fluorescence Intensity values




I’ve been using Cell Profiler for a while and I’m using a pipeline that measure object intensity. The problem I’m having is that I can check cells average intensity in Fiji and find that there are great discrepancies between what I measure in Fiji and Cell profiler. I understand that cell profiler normalizes the images intensities but I can easily find value in the thousands for mean intensity in Fiji and only get mean fluorescence less than 1 in cell profiler ( and in the hundreds for integrated intensity) even after rescaling to full intensity range. I’ve tried rescaling image intensity with no avail. Is there something I’m missing?


P.S. I’m using version 2.2



CellProfiler rescales all images 0-1, so all the values are going to be either 1/4095, or (more likely) 1/65535 the values you calculate in FIJI. Mean fluorescence in CellProfiler will therefore always be 1 or less (since 1 is the maximum), and integrated intensities in the hundreds seem pretty reasonable (assuming your objects have diameters of ~>40 pixels).

Does that help at all?


Yes it does help. I realized I was selecting the wrong image when I was measuring intensity, so the values are much more reasonable.

I have new issue though my images are scaling funny. Cells in dim images are scaling to be the same as my brightest images.

This is an example of a dim image.

This is an example of a bright image.

I tried streching each image to use the full intensity range.

I tried making a pipeline for analyzing just the two image sets and I keep getting an error:
Traceback (most recent call last):
File “cellprofiler\pipeline.pyc”, line 2341, in prepare_group
File “cellprofiler\modules\rescaleintensity.pyc”, line 284, in prepare_group
File “cellprofiler\pipeline.pyc”, line 2049, in run_group_with_yield
File “cellprofiler\pipeline.pyc”, line 2067, in run_module
File “cellprofiler\modules\namesandtypes.pyc”, line 1409, in run
File “cellprofiler\modules\namesandtypes.pyc”, line 1461, in add_image_provider
File “cellprofiler\modules\namesandtypes.pyc”, line 1494, in add_simple_image
File “cellprofiler\modules\namesandtypes.pyc”, line 1521, in add_provider_measurements
AttributeError: ‘MonochromeImageProvider’ object has no attribute ‘scale’

I switched to Version 3 and am still having the same problems.


Can you upload your pipeline (and original images if it’s anything other than the jpegs you embedded earlier, feel free to use dropbox/google drive and posting a link if you’re worried about image embedding issues) please? That’ll help troubleshoot this.

Here you go! The images are Tiffs but I always have trouble uploading them so I converted them to embed in my previous reply.


It seems to be due to the “Minimum of all images” and “Maximum of all images” setting you used in RescaleIntensity- I’ll file a bug report on that, but the good news is that you don’t need to wait around to get it fixed. You’re much better off anyway just setting 0-1 to 0-65535 (that way you can compare between analysis runs more fairly); if you do that it should run fine and you’ll get values that look much like this chart I just made by quickly scatterplotting in Excel the output CSV.



I’m sorry. I’m trying to repeat what you did and I’m not getting the same results. Could you take a screen shot of the settings you have for the RescaleIntensity module.


Sure! Here they are.

You may need to save the pipeline, close, and reopen CellProfiler to get it to work; I did NOT need to do that, but the only other report of this bug the person reported they did have to close and reopen to get it to work. Try that as well.


Thank you very much! I got it to work but the values of the low image are pretty high still.


Well your background is low, but it’s not 0; this could be due to camera noise (due to that plus some extra room for “safety” most cameras don’t truly start at 0), autofluorescence, or some combination of the two.

Integrated intensity is area*mean intensity- your average area was ~3000 pixels (according to MeasureObjectSizeShape)

When I divided the integrated intensity values I just posted above by 3000 I got a range of average intensity centered around ~100, which is just what you’d expect from this histogram.

If you want it to be truly 0, you can due some background subtraction before rescaling and measuring.


Sounds good. Thanks you so much for all the help. :grin: