Issue with exporting excel file from statistics

Hello,

I have a set of measurements from the statistics window that I would like to export. I’ve tried copy/pasting measured values directly from the statistics window, but I almost always get errors in the pasted data (huge gaps in numbers, numbers that should be in microns paste as pixel units). In order to get it to work, I have to copy/paste small sections of the data into excel, a few hundred values at a time.

Instead, tried to export the data as .xlc but no file was saved. I could save the data successfully as a .mat but we don’t have Matlab on all of our computers, so it would be nice if I could do this without exporting a .mat file.

Any help with this would be greatly appreciated!

-Connon

Hi Connon,
thank you for this comment, it is sorta a known issue, at least I reported it to Mathworks in the beginning of 2016. The reason is that the table view does not load all the data and as result copy/pasting behavior works only for smaller number of entries in the table. Naturally the best way to export results is just to save them in Excel or Matlab format. We do not have any issues with export to Excel, but I will double check that tomorrow.
Could you please specify, which version of MIB do you use and what is your OS?
Do you see any errors in the command window?

I can suggest two options:

  1. try MIB for the recent version of Matlab (http://mib.helsinki.fi/web-update/MIB2_Win_Recent.exe), it is compiled for Matlab R2019a and possibly this may have been sorted there, I will try to check it tomorrow.
  2. alternatively, I can make a quick fix and add export to comma-separated values.

Update, I tested copy numbers from the table on R2019a and it is still the same issue. I will come with a way around it.

Best regards,
Ilya

@connont,
I updated MIB for Matlab and Windows (version 2.511).
Now you should be able to copy the full list via the right mouse click or save to CSV file using the Export button at the bottom.

Hi Ilya,

Just to answer your previous questions, I’m using the standalone version for Windows, version 2.51. There were no errors in the command window, it says it exported .xls it to the directory, but it doesn’t show up in the folder.

Anyway, your fix is perfect, thank you so much for your quick response!! This is why I love MIB :slight_smile:

-Connon

glad it worked!
was it 2.51 for the recent release of Matlab or for R2017a?
It would be nice to fix it, but I can’t reproduce the problem (yet)… :frowning:
Ilya

I believe it is the R2017a version.

I just tried to do it on another computer and it worked fine, of course! Not sure what the deal is, but it looks like an issue on my end. Thanks!

-Connon

1 Like