Issue with Big Warp

Hi, I am trying to align a 3D light sheet data set with a DWI MR image. I have converted both files to .xml/H5 files with success through BigDataViewer; however, when I try to use the actual BigWarp plugin with my open data sets, the light sheet data set (which is stored as an XML file- 2 KB backed by the H5 file- ~200,000,000 KB) opens very poorly. My best guess would be that the entire light sheet data set is opening but in a very compressed way that makes the image viewable through only around ~300 increments of the z axis (and this is NOT the case when I open the converted XML file just through BigDataViewer). In other words, it is making it almost impossible to accurately choose landmarks. I would like to point out that the much smaller DWI image opens just fine in Big Warp! Any ideas on how to solve this?

1 Like

Hi @claraDu2022

Welcome to the forum.

Thanks for reporting this problem.

Some follow up questions:

  1. How did you make the h5 file? Was it with the bigdataviewer save as xml/h5 menu option in Fiji?
  2. How did you open the xml/h5 file with bigwarp? Was it with this script?

John

Hi John,

The light sheet data was originally opened as an image sequence with 2500 TIFF files. I then went into the BigDataViewer plugin and exported the image sequence as XML/HDF5 file. I then imported the newly created xml files into fiji and opened the BigWarp plugin with the open images and proceeded to select the moving and target image. Would this be better done with the “BigWarp apply” method?

Hi @claraDu2022,

Thanks for following up. I have ideas for what to do that I outline below.
(This should have been documented better btw, I’ll going to update the bigwarp wiki page).

John

Try this:

If this doesn’t work read below, and tell me where I’m misunderstanding. Or, if it does work, see below for a likely explanation of what happened.

  1. Make a new folder in your Fiji.app directory: Fiji.app/scripts/bigwarp
  2. Download this script, and put it in the folder your created above.
  3. Restart Fiji, and notice you have a new bigwarp menu option.
  4. Run bigwarp > BigWarp ImagePlus or Xml
  5. Select your xml file for the lightsheet data in the dialog as appropriate, and press okay.

After this, your lightsheet image should (hopefully) behave the same in bigwarp as it does in the bdv xml plugin.

If it doesn’t please answer my question below, and I’ll try to help you figure out what’s happening.

If it does work, also please let us know :slight_smile:

What may be happening

Could you explain in more detail what you mean by this:

I have an idea what may be happening, but please correct me if my understanding of what you did is incorrect.

The bigdataviewer (bdv) plugin that writes the xml & h5 files creates a pyramid of images. This makes it possible to quickly load a downsampled view of the whole field of view when zoomed out. It also means that when you zoom in, bdv only has to load a small part of the high-res data.

The “normal” bigwarp plugin (Plugins > Big Data Viewer > BigWarp) may not have access to all the different resolutions if you import the xml/h5, but only the (probably low) resolution that was loaded. I think this is why the LightSheet image looks bad in bigwarp.

The solution is to tell Bigwarp about the xml/h5 files directly - and this will let it load all the resolutions the way the normal bigdataviewer plugin does (see above).

2 Likes

Hi John,

I downloaded the script, and sure enough, both of the images open great now! I think you are right about the problem; it was definitely clear that BigWarp did not have access to all of the resolutions of the light sheet data. Thanks so much for all of your help:)

2 Likes

@claraDu2022 you can mark any of the answers as the solution to your question. This will mark the topic as solved in the topic list and other users with similar problems can jump to the correct answer right away.