Issue opening ImageJ on a remote Linux system

fiji
imagej

#1

Hey!

I’ve been trying to run ImageJ off a remote linux system and keep getting this error when I input the command “ImageJ-linux64”. ImageJ fails to open afterwards, instead I just get this error message.

No GUI detected. Falling back to headless mode.
No GUI detected. Falling back to headless mode.
Java HotSpot ™ 64-bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
Java HotSpot ™ 64-bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

Previously, before I ran into this problem, the last 2 lines in the error message would appear but the program would open fine so I thought nothing of it. Now, suddenly, I’m getting the new first 2 lines and I don’t know why.

Oddly enough, when I try to open ImageJ on the remote Linux system from a different computer using the same method, I don’t get an issue. So for some reason this computer is getting that error message while others are not.

I’m quite inexperienced with this stuff so I don’t know if there is an easy fix, but I would appreciate your input.

Thank you!


#2

Hi @Ala,

Why do you say ImageJ fails ? If you are running it remotely, then there’s no graphical interface and that’s the default behaviour. You can add --headless to avoid the lack of GUI notification message.

If you want a GUI to appear, then in a remote session, one way is to make X forwarding. On linux just connect with ssh -X.

Best

Nicolas


#3

Hi NIcoKiaru,

Thanks for your input.

I suppose it doesn’t fail, or maybe it does, but no GUI appears which is normally what happens in the past when I ran that command.
I am using Xming and X11 forwarding when connecting to the remote computer, and that’s usually what allows me to have the GUI appear on my local computer. And in the past, just by using the command ImageJ-linux64 I was able to have the GUI appear.

I tried using the ssh -X command you mentioned but that doesn’t resolve the issue.

Thanks again for the help!


#4

On windows ? Linux ? Mac ?


#5

I’m on a Windows 10 operating system trying to connect to a computer running CentOS


#6

Okay, I just consulted with a colleague and he pointed out an error I was making.

Before connecting using Putty, I didn’t check “X11 Forwarding” before connecting. But after checking that box, my problem is resolved, and ImageJ GUI is opening.

Thank you for your help NicoKiaru.