ISSUE: Duplicate images not saving

Hi all - I was wondering if anybody could help me.

When I duplicate an image (with annotations), edit it and then save it, when I reopen the software, it is no longer there.

I tried opening the log, and when an image is saved, it comes up with INFO: Image data written in 0.01 seconds, suggesting that it has saved. However, once the software is closed and then reopened again (e.g. if I turn my laptop off), the duplicated images and any changes I made to them are no longer there.

This is just limited to duplicates, as I tried editing the original files and they saved fine. It is also worth noting that the first lot of duplicated images worked fine - it was when I went to duplicate for a second time that it happened.

For context: I have drawn lines of a certain length, and am counting mitotic figures along the length. As I am very new to histology, I wanted to make sure I got the same result at least a few times before I trusted the myself, and so I have been duplicating the images, deleting the counted cells, but retaining the lines I’d drawn.

Any help would be really really appreciated - I am a PhD student and just have no idea what I am doing, and have lost a few hours of work due to it not saving.
Best wishes,
Amyleigh

Which version of QuPath are you using?

I have created a whole bunch of duplicates, and duplicates of duplicates, so there doesn’t seem to be any problem there.

Can you confirm that when you are duplicating that a new data folder is also created?


image
Becomes
image
in the Project “data” folder when I click ok to create the new duplicate.

Hi - thanks so, so much for your quick response!
I am using what I believe to be the newest version which is 0.2.3.

I have just looked, and a new data folder has been created, which is a relief (I hadn’t thought to check that, so thank you!), but it doesn’t seem to open along with the rest of the project in qupath.

I am completely stumped!

I haven’t seen that before, and @petebankhead might have a better idea of what is going on, but it sounds like your project.qpdata file might not be updating when you exit QuPath?


I am curious if your qpproj and backup version have similar timestamps, or if maybe the qpproj has a much older timestamp.

Also, to check your data, you could try duplicating your image again, and then dragging the data.qpdata file from a given folder into the open QuPath window. Not something I would normally recommend, but it might let you see if your data is still there.

I checked the data file and the backup - the data file was last updated about 10 mins ago, which is when I last pressed save, so that makes sense.
The backup was last updated on the 17th (which was when I got this new laptop. It is worth noting though I’ve used QuPath successfully on this laptop and it saved ok, so it’s not a just this laptop issue).

Great suggestion re the dragging the datafile from a folder into qupath - it has opened and appears my work has saved, so all is not lost. So it seems the main issue is that it just isn’t opening with the main project file.

Thanks again for the help!

Not sure if it is possible, but it might help Pete to show a picture of your directory structure and Project tab. And OS, I forgot to ask about that I think.

Maybe Pete will have an idea. It feels more like an IT permissions type of issue though. Something is blocking files from being written or edited, though I am not sure why it would allow the data file to be changed and not the project file. Possibly anti-virus (or the Windows10 ransomeware protection).

Sorry for the stupid question (I am completely clueless on this stuff), but when you say directory structure, what do you mean?
Some extra detail that may be important:

  • I am using windows 10
  • It is a work laptop and it is saved to my work drive via the VPN.
  • The images themselves are on an external hard drive (files are too big/too many to fit on laptop), so each time I open the project I have to select the hardrive so it knows where to find them. The project itself is saved to my work drive, though.
    I have attached a photo of part of the project tab (I think that’s right, although tell me if I’ve put on the wrong thing!).

Ah, nevermind, the directory structure of your project is not likely the problem so much as all of that. Or some part of all of that. I couldn’t say precisely what. I would recommend starting a new project and trying to duplicate the issue on your local hard drive, or on the external hard drive itself (save the project folder there).

That could at least limit the issues. I work with QuPath locally or on the network and images locally or on the network all the time, but not usually through VPN. I am not sure what complications that might cause with the URIs (file paths).

Sorry - I should have included those details originally but didn’t think they were important. I’ll give that a go and let you know if it works.
Thanks so much for all of your help!

1 Like

It seems to be working now I’ve moved it to the local hard drive - thank you so so much for your help, you’ve saved me a lot of stress!
I hope you have a lovely Christmas if you celebrate it :slight_smile:

1 Like