Is here a movement for migrating deeplabcut to tensorflow 2?

Hi, as far as I understand DLC depends on tensorflow-slim that does not work wit TF 2. Is there a movement to migrate TF-slim to tf2 or DLC to tf2 withoiu tf-slim? Many thanks

richard

1 Like

Any updates on this matter? I am installing DLC (version 2.1.10.3) with tensorflow 2.1.0 and CUDA 10.1, but running into errors

Yes! Have a look at DeepLabCut-core here GitHub - DeepLabCut/DeepLabCut-core: Headless DeepLabCut (no GUI support), which a headless version of DLC working with TF2. We’re testing it more but should be incorporated into the main repo quite soon :slight_smile: