Installation on mac + GUI issues?

Hello,
Working with macbook pro, using MacOS Mojave (the issues occured in either version 10.14.2 or 10.14.6). I’ll share some of the issues that I experienced in the last few days hoping that it’ll help in the diagnosis.
I tried installing deeplabcut in two ways:

  1. first attempt - I created a conda virtual environment with python 3.6 and once in it, tried to pip install deeplabcut.
    This raised the following error:
    ERROR: Exception: Traceback (most recent call last): File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/cli/base_command.py", line 188, in main status = self.run(options, args) File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/commands/install.py", line 345, in run resolver.resolve(requirement_set) File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/legacy_resolve.py", line 196, in resolve self._resolve_one(requirement_set, req) File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/legacy_resolve.py", line 359, in _resolve_one abstract_dist = self._get_abstract_dist_for(req_to_install) File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/legacy_resolve.py", line 307, in _get_abstract_dist_for self.require_hashes File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/operations/prepare.py", line 199, in prepare_linked_requirement progress_bar=self.progress_bar File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/download.py", line 1064, in unpack_url progress_bar=progress_bar File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/download.py", line 928, in unpack_http_url unpack_file(from_path, location, content_type, link) File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/utils/misc.py", line 735, in unpack_file flatten=not filename.endswith('.whl') File "/anaconda3/envs/DLC/lib/python3.6/site-packages/pip/_internal/utils/misc.py", line 631, in unzip_file shutil.copyfileobj(fp, destfp) File "/anaconda3/envs/DLC/lib/python3.6/shutil.py", line 79, in copyfileobj buf = fsrc.read(length) File "/anaconda3/envs/DLC/lib/python3.6/zipfile.py", line 872, in read data = self._read1(n) File "/anaconda3/envs/DLC/lib/python3.6/zipfile.py", line 948, in _read1 data = self._decompressor.decompress(data, n) zlib.error: Error -3 while decompressing data: invalid code lengths set

Didn’t understand the error, and then moved to:

  1. Easy installation using the dlc-macOS-CPU.yaml file. The installation went smooth. Then I opened the terminal, and once inside the virtual environment, typed in
    pythonw
    import deeplabcut.
    I was able to create a new project and copy videos to that folder.

Then, when executing:
deeplabcut.extract_frames(path_config_file, crop = True)
the GUI opened up, i was able to mark the desired rectangle but then when I quit the GUI the terminal session was just stuck, as if still running. This was solved by
import matplotlib
matplotlib.use('Agg')
before running deeplabcut.extract_frames().
That is, frames were extracted and saved in their cropped version the labeled-data folder.

Moving on to
deeplabcut.label_frames(path_config_file)

The GUI opened, when I tried to select a folder of frames I wasn’t able to do so, and got the following error:
objc[47978]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff9b47d210) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x141e1ddc8). One of the two will be used. Which one is undefined. Traceback (most recent call last): File "/anaconda3/envs/dlc-macOS-CPU/lib/python3.6/site-packages/deeplabcut/generate_training_dataset/labeling_toolbox.py", line 428, in browseDir self.cfg = auxiliaryfunctions.read_config(self.config_file) File "/anaconda3/envs/dlc-macOS-CPU/lib/python3.6/site-packages/deeplabcut/utils/auxiliaryfunctions.py", line 125, in read_config raise FileNotFoundError ("Config file is not found. Please make sure that the file exists and/or there are no unnecessary spaces in the path of the config file!") FileNotFoundError: Config file is not found. Please make sure that the file exists and/or there are no unnecessary spaces in the path of the config file!

at other runs the GUI opened an image (can’t reproduce what made it happen, maybe some other matplotlib backend that I tried, or downgrading it), yet I wasn’t able to mark labels on the screen (tried using right or left clicks).

I validated that the config file was indeed in the right place with the right name, corresponding to the current working directory (also, otherwise it won’t execute extract_frames(), right?).

Do you have any suggestions?

P.S I also posted the question here in a closed issue in AlexEMG/deeplabcut (i’ll remove it from there if needed.)

@AlexanderMathis
Making sure that someone sees my question.
Thanks…

please use the supplied anaconda environment for macOS, vs building your own, also be sure to use pythonw: www.deeplabcut.org