Installation in Centos6 fails

cellprofiler

#1

Hi all. I am trying to install Cellprofiler on a CentOS machine (6.9). I would love to be able to install a stable release; but I have not been able to find such a thing. The Linux download links in the web page are disabled. All I have been able to find are instructions for installing from source which are available in the wiki and state:

Install the Java Development Kit (JDK)
Install Python
Install Cython, matplotlib, NumPy, and SciPy with pip
Clone the CellProfiler repository
Run pip install -e . from the CellProfiler directory

I have all requirements installed. I have used git to clone the repo (latest, no specific release stated). Running pip install in the directory yields:

[root@tritium CellProfiler]# pip install -e .
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Obtaining file:///home/fernando/CellProfiler
CellProfiler requires Python ‘>=2.7, <3’ but the running Python is 2.6.6

which makes sense as Centos ships with 2.6 AFAIK


#2

Hi,
Our SWE is sad to report that no, there’s no way to install any recent versions of CP (2.2 or 3.0) with Python 2.6; he recommends trying to get Python 2.7 (he recommend pyenv, I also found a tutorial here) installed additionally to run CP from.

Good luck!