Index Problem with MeasureObjectIntensity?!

Hi all, I’ve got a problem with the MeasureObjectIntensity module as it always gives me the error message “Invalid Index Type”. I attached an example pipeline and some images. I know the images are very low contrast, but I don’t think that’s the problem as the pipeline is able to measure shape and size of the nuclei (so they do seem to exist), and I tried the speckle counting example from the web as well and got the same error message. Has anyone else come across that problem?! Any help would be highly appreciated! Thanks a lot, Irina
pipelinehelp.cp (5.67 KB)






and this is the complete error message… i hope that helps!! thanks, irina

traceback (most recent call last):
File “/amd/kronecker/2/package/cellprofiler/31052010/cellprofiler/pipeline.py”, line 305, in run
self.module.run(self.workspace)
File “/amd/kronecker/2/package/cellprofiler/31052010/cellprofiler/modules/measureobjectintensity.py”, line 291, in run
integrated_intensity = fix(nd.sum(img, labels, lindexes))
File “/package/python/2.6.3/x86_64/lib/python2.6/site-packages/scipy/ndimage/measurements.py”, line 124, in sum
raise ValueError(“Invalid index type”)
ValueError: Invalid index type
Tue Jul 6 17:03:22 2010: Image # 1, module MeasureObjectIntensity # 7: 0.11 sec (bg)

Hi Irina,

It seems like the issue you describe and the issue on this thread are related. Does the solution there help at all?

Regards,
-Mark

Hi Mark,

Thanks for the quick reply! We updated CP but I still get the same error. I noticed though that when I start CP, I get the following warning which seems to be related to the error…


./start_cellprofiler
running build_ext
Using jdk_home = None
Using jdk_home = None
running build_ext
running build_ext
/package/python/2.6.3/x86_64/lib/python2.6/site-packages/pytz/init.py:29: UserWarning: Module decorator was already imported from /amd/kronecker/2/package/cellprofiler/31052010/decorator.pyc, but /amd/lethe/0/scratch/package/python/2.6.3/x86_64/lib/python2.6/site-packages is being added to sys.path
from pkg_resources import resource_stream

(python:835): Gtk-CRITICAL **: gtk_range_set_range: assertion `min < max’ failed
Subversion revision: 10027
Pipeline saved with CellProfiler SVN revision 10027


does that mean we didn’t set up CP correctly?

Thanks so much!!

Irina

Hi Irina,
We had problems similar to this on our Unix cluster machines. I’ve just recreated your problem using Scipy 0.71 and I believe that the fix that you need to Scipy is in Scipy 0.80 rc2. I don’t have a version of that built for Unix - we built Scipy from a checkout of revision 6392 from the trunk. 0.80 is later than that, so it should work. What version of Scipy are you running? You can type:

python -c "import scipy;print scipy.__version__"
to get the version #.

The warnings that you’re seeing are spirous - we have added decorator.py to our code base.

Hope this helps.

–Lee

Hi Lee,

The Scipy version we’re using is indeed 0.7.1… I’ve passed the problem on to the proper IT people who said they can help :smile:

Let’s hope that rebuilding Scipy resolves the problem!

Thanks for now!

Irina