Increase the usage of available memory

hi there,

I’ve 120g memory.

I did:

bin/omero config set omero.jvmcfg.strategy manual
bin/omero config set omero.db.heap_size 40g
bin/omero admin restart
bin/omero admin jvmcfg

and got:

JVM Settings:

blitz=-Xmx512m -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’})
indexer=-Xmx512m -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’})
pixeldata=-Xmx512m -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’})
repository=-Xmx512m -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’})

what did I wrong ?
I expected more memory to be used…

best regards
~a

How did you come to try setting omero.db.heap_size? You may find https://docs.openmicroscopy.org/omero/5.5/sysadmins/server-performance.html#memory-configuration to be a useful guide.

Agreed. With the manual strategy, I’d think you are looking for a setting such as:

$ bin/omero config set omero.jvmcfg.heap_size.blitz 64000

oooh … sorry: typing error :-/

know it looks better:

bin/omero admin jvmcfg
JVM Settings:

blitz=-Xmx40g -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’, ‘heap_size’: ‘40g’})
indexer=-Xmx40g -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’, ‘heap_size’: ‘40g’})
pixeldata=-Xmx40g -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’, ‘heap_size’: ‘40g’})
repository=-Xmx40g -XX:MaxPermSize=128m -XX:+IgnoreUnrecognizedVMOptions # Settings({‘strategy’: ‘manual’, ‘heap_size’: ‘40g’})

BUT:

can Java now consume 160g?

That is of course to much…

~a

Looks like it.

I assume you can adjust the above to meet your targets? :slight_smile:

~J.