Incorrect # of channels when opening up CZI files in Fiji using Bioformat

1_MIP_TIFF_today.czi (12.2 MB)

Hi Everyone,

I was hoping you could help me figure out why FIJI has an issue opening up my CZI files.

I upload my CZI files using bio format importer.

The meta data of my CZI file says I have 4 channels, yet when I import into FIJI, it opens up 12 images and says I have 12 channels. It should only be 4. Does anyone know how I can fix this? I’m trying to stitch multiple images together, but can’t even seem to upload the images correctly. Thank you!

Hi @l9inds, this looks like it is likely a bug in the Bio-Formats reader. Can you confirm what you expect the correct Pixel Type to be? Bio-Formats is reading it as BGR_24 and therefore seems to be multiplying the total sizeC by 3 thinking that each channel is 8bit rgb.

Hi,
Thank you for getting back to me.
So I take the images at 8bit depth, yet when I create a maximum intensity projection (MIP), for some reason the meta data indicates that it’s now at 24 bit depth.

.

So perhaps it’s an issue with the zen software when I create the MIP?

I tested by creating an MIP in Zen Blue (3.1), the bit depth does not change by default, for regular confocal or Airyscan images. Maybe you are doing something else?

Zen Blue also stripped the File Information off of the images when the MIP was created, which it does not seem to have in your example.

Hi thanks!

I tried creating the MIP again and saving, and now it works!
It appears if I click on “Save as CZI” in the file menu, it’ll do so correctly. But if I do “File” > “Save” > and change the file format to CZI, my file will get messed up (if this helps anyone in the future."

Now to figure out how to stitch these files correctly…

Thanks a bunch!

2 Likes