Importing DeepLabCut: Procedure entry point could not be located

deeplabcut
#1

Hello, I am attempting to install DeepLabCut on a windows computer but have been having some issues along the way.

I currently have everything installed that the documents have said to install (i.e anaconda, deeplabcut, the specific environment and TensorFlow [no gpu]). I seem to get an error when I try to import deeplabcut within python (see attached). It seems to be unable to locate a specific file within a given library. Any help would be appreciated. Thank you.

deeplabcut2

0 Likes

#2

the documentation says " you must use pythonw vs. ipython". use ipython.

0 Likes

#3

I have used ipython as well and have gotten the same error

(the file that it claims it can not extract the library from, is within the path it is showing)

0 Likes

#4

can you import tensorflow?

0 Likes

#5

Yes, no error with that.

0 Likes

#6

strange; can you start a TF session?

Which version of TF do I have installed?

tf.__version__

can I start a TF session?

sess = tf.Session(config=tf.ConfigProto(log_device_placement=True))

seems an error with your python install in relation to tensorflow though…

0 Likes

#7

Here is what I can find:

0 Likes

#8

^ just to clarify, no you can use python as well, but if you use MacOS you need to use pythonw

0 Likes

#9

tf version is 1.10.0.

I can not start a session. I get this error:

0 Likes

#10

okay so tensorflow is not installed properly. Did you use this file to create an environment? If, not, please try this:

and, if you did it is somehow broken. so remove the env, and try again.

conda remove --name myenv --all

here are some conda tips: https://docs.conda.io/projects/conda/en/latest/user-guide/tasks/manage-environments.html

0 Likes

#11

Yea I have been using that environment. I just uninstalled tensor flow, removed the env, remade the env and then reinstalled tensor flow. But that did not fix the issue either.

0 Likes

#12

but don’t update, make a new env: conda env create -f dlc-windowsCPU.yaml

otherwise, I have no idea, it is a tensorflow issue, so I would look on StackExchange, their GitHub etc for solutions.

0 Likes

#13

I was able to get it to work. Thank you for the help.
Turns out I had to move all the .so files out of their corresponding locations and just put them somewhere else (the desktop for instance). Not sure why this worked but i was able to import deeplabcut

1 Like