Import options do not work

1- I have just noticed when uploading image in OMERO that the checkbox options to skip "tumbnails generation, min/max calculation, & checksums’ don’t work! I got the same results as when enabling the 3 checkboxes!
2- at the import too, the “Folder as Dataset” is disabled and I can not check t?

any idea about, please?
using version 5.4.10-ice36-b105, and waiting for the upgrade to the last one.

hank you


Hi Nabila,

what do you mean with “Folder as Dataset”? There is a “New from Folder” Dataset option, but that’s not a checkbox, just an option in the dropdown menu. It means the images will be imported in a newly created dataset which name matches the folder name where the images are located on the filesystem.

How big are these images? You will only see an effect for very large images. The min/max calculation step creates initial rendering settings for the image and the thumbnail generation process creates the thumbnail. By default this happens directly after the file import. But if you skip it, then these processes are triggered when you first request the thumbnail of the image (ie. when you open the dataset). For small images this happens so quickly that you can’t really notice a difference.
For the checksum step you won’t notice a difference either, unless the file is so big, that the checksum calculation takes up a significant amount of time.

Kind Regards,

Hi Dominik,
You are right for all! the size of the image is 4GO for example!!
No difference in time between import with & without checksum/min-max/thumbnails. it tooks 2mn25s!!
I was wondering for any adrvice to escape or not these options for more speed.

Many thanks


To be honest, I don’t think disabling these options in Insight makes much sense. If you are thinking about more elaborated / large scale import workflows you should have a look at the command line interface: